Having trouble running some games with newly built PC.

CheesyNacho

Honorable
Jan 10, 2013
2
0
10,510
I just built a new PC, here are the specs:

AMD Phenom 2 x4 CPU
Radeon HD 6570 GPU
8 GBs of RAM
Asrock 760GM-GS3 MicroATX Motherboard

Not the beefiest machine on earth, but still can run things. I've tried to run TF2, Orcs Must Die 2, Terraria, Bastion , and The Binding of Isaac, but only Isaac has worked. All the rest simply crash to the desktop immediately after launch. Bastion gives me this error:
"No suitable graphics card found. Direct3D hardware acceleration is not available or has been disabled. Verify that a Direct3D enabled graphics device is installed and check the display properties to make sure hardware accelleration is set to Full. This program requires pixel shader 2.0 and vertex shader 1.1"
I've tried installing DirectX, installing the latest drivers from the AMD website, and putting "-dxlevel 95" in the TF2 launch options on Steam.
When I go to the advanced screen resolution settings, instead of a graphics card, it says "Standard VGA graphics adapter".
This leads me to believe that for some reason, my graphics card isn't being properly detected, especially that Bastion error. I don't know where to go from here, any help would be appreciated!
 

beeding

Honorable
Dec 18, 2012
120
0
10,710




You don't have a great video card.
 
Based on the errors, I bet that you are using the on board IGP rather than the 6570. While the 6570 isn't strong, it does support pixel shader 2.0.

Check your BIOS or user manual with that motherboard, and see if you need to enable the discrete card, or disable the IGP.