Question Having trouble with samsung blu ray player

berlin88

Distinguished
Oct 23, 2009
108
3
18,685
0
I have a Samsung UBD-M8500/ZA 4K UHD Blu-Ray Player that I purchased in 2017.

I am currently having two problems with this device:

Problem 1:

Periodically when I try to play a music CD or Blu Ray disc, the UBD-M8500 will shut itself off and then forces me to go through the setup process all over again. Why does it do this? It has happened three times in last month.

Problem 2:

When I tried to go through the setup process today, I got to the part where it asks you to login to the account, but when I try to log in, it says to try again later. This prevents me from completing the setup, and thus prevents me from using my device.

When it says to try again later, how long do I have to wait? I tried waiting 15 minutes, but it said the same thing again when I tried to log in.
 

robert600

Distinguished
Jan 19, 2012
1,225
39
19,690
151
I have the k8500 which is likely very similar to yours but as I've not had any issues with it so far, I can't really help you directly. Personally I use the AVSforum for this kinda stuff ... the members on the k8500 thread are very helpful ... I'm sure the ones on the m8500 will be too.

Here's a link to the m8500 thread (you'll have to join to post):

 

berlin88

Distinguished
Oct 23, 2009
108
3
18,685
0
I have the k8500 which is likely very similar to yours but as I've not had any issues with it so far, I can't really help you directly. Personally I use the AVSforum for this kinda stuff ... the members on the k8500 thread are very helpful ... I'm sure the ones on the m8500 will be too.

Here's a link to the m8500 thread (you'll have to join to post):

I eventually got it to work. I waited until well after midnight before trying to log in again, and it worked fine. I was able to complete the setup and use my blu ray player again.

I still have no idea why it randomly makes me go through the setup process all over again, but as long as it works, I can live with the inconvenience of having to go through the setup process again every once in a while.
 

robert600

Distinguished
Jan 19, 2012
1,225
39
19,690
151
Well ... now that you can get in ... I would look to see if it's on the latest firmware and ... do a factory reset. Apart from that, I don't think there's a whole lot you can do ... as you say, sometimes you just have to live with these mysterious glitches.
 

ASK THE COMMUNITY

TRENDING THREADS