HD Radeon 5770 Updating problem*severe*

robvils

Distinguished
Sep 11, 2011
10
0
18,510
Hi, First time posting here.

I have a Radeon HD 5770 and every time i try and update the drivers from the ones it came with i get severe screen tearing and it was cause the computer to auto restart as well..im not to sure what the problem is i have uninstalled the drivers before installing and i have also tried a new monitor as i heard it might have been that...

thanks for any an all help

win7/AMD Phenom II 6x/ Asus M4A785-M
 

farrengottu

Distinguished
Aug 28, 2011
912
0
19,160
try uninstalling them from safemode.
incase you dont know how to get into safemode.
hit F8 a lot of times while booting. select safemode or safemode with networking from the selection screen.
safemode is just windows without any drivers or programs started.
 

robvils

Distinguished
Sep 11, 2011
10
0
18,510
i have tried uninstalling and reinstalling using the driver sweeper..the driver seem to have worked..went to look at the new CCC that i can use and notice that my card is completely clocked down to lowest setting..i try to turn up and the problem reappears.. anyone have an idea?

I can turn the clocks up but whenever i check the *enable AMD overdrive* is when the problem appears
not sure if turning the clocks up without the box checked does anything as i seem to be newb
 

robvils

Distinguished
Sep 11, 2011
10
0
18,510
the subvendor is ATI AIB (1787)..thanks again for all the help you have been providing..just taking the time to show me these programs are a huge help..thanks again
 

robvils

Distinguished
Sep 11, 2011
10
0
18,510
i was able to clock up the speed a bit from the default setting with no problems so far...but although it says its clocked up when i test is Kombuster or the sensor in GPU it says its clocked at below the default

Current clock set at-910
Default clock -850
Sensor and kombuster read at -400