Question HDD is not given power and is not read when case fan is connected

Mar 5, 2019
20
0
10
0
So, i took my case's front fan out to clean it and then i plugged it back in, i don't remember if it was the same molex connector as before removing it.
everything powers up fan spins pc boots and goes into the bios and hdd is not read so it doesn't boot.
i remove the fan and then it boots up like normal.
So why did this happen?
 

boju

Titan
Ambassador
Open case, look behind the hdd. There will be two cables, one for data connecting to the motherboard and another cable providing power. This power cable leads back to the power supply (psu).

Find out how the hdd and fan power cables have been arranged.
 
Mar 5, 2019
20
0
10
0
Open case, look behind the hdd. There will be two cables, one for data connecting to the motherboard and another cable providing power. This power cable leads back to the power supply (psu).

Find out how the hdd and fan power cables have been arranged.
ok so i have 3 molex and one 4 pin small cable I'm assuming for fan directly to psu and the cable with the hard disk also has a molex connector
 

boju

Titan
Ambassador
Yeah, make sure the molex cable the hdd is connected to is plugged in good and if possible move the fan's molex connector to another molex plug. Follow the molex wire from hdd and see what else is connected to it. Molex cables can have more than one plug so maybe try not have too many devices connected to the same wiring loom.
 
Mar 5, 2019
20
0
10
0
but the
Yeah, make sure the molex cable the hdd is connected to is plugged in good and if possible move the fan's molex connector to another molex plug. Follow the molex wire from hdd and see what else is connected to it. Molex cables can have more than one plug so maybe try not have too many devices connected to the same wiring loom.
i think my hdd is powered with SATA the cable goes on and powers optical drive with SATA and the end is a molex connector which is free
there are total 4 molex and right now all of them are free before one powered the fan but after i connected the fan back to probably a different connector the hdd didn't work and upon removing the fan it works
i haven't tries other molex ports yet
P.S how do i insert a picture in my replies?
 

boju

Titan
Ambassador
Maybe. Hdds/fans don't consume a lot of power so could only guess a loose connection or short in a wire (worst case).

Long as it's running. Maybe tape the one that's bad and investigate later on.
 

ASK THE COMMUNITY