HDD not showing up in windows

ryan646

Distinguished
Dec 15, 2008
76
0
18,630
0
My specs:

Processor: I7 8700
Mobo: Msi z370 sli plus
Storage: 120 GB sata ssd for OS
32 GB optane
2 TB Toshiba hdd
500 GB Samsung 970 Evo m.2 nvme (new)
Ram: 16gb
Graphics: msi 1070ti


I installed the new Samsung 970 m.2 nvme ssd the other day. When starting up my pc, there was a m2 genie error so I had to load back to the default settings to start up again. I did not setup the bios myself before it was all done from the shop I purchased the pc from.

Now windows wont detect my older 2TB hdd that was almost full (which is why I got the new ssd). From what I've seen online the common solution is to enable/allocate from disk management, but it does not show up there.

I am not too familiar with the bios either. It only shows sata 0 which I am assuming is the OS ssd, and it does not start on AHCI, only in raid. I reconnected the cables and still nothing shows up.

Can someone please help me figure out what is wrong and how to fix it
 

ryan646

Distinguished
Dec 15, 2008
76
0
18,630
0


i dont know, but I tried changing to AHCI and it doesnt even start up. Goes into windows diagnostic and tries to repair drive and fails.
 

karenjoly

Respectable
Apr 13, 2018
1,329
20
1,815
187
The solution is to switch the drive controller Mode to AHCI from RAID. The long method is to reinstall windows setting AHCI prior to the install. The short method is to switch within windows using these steps. Like all such ops, back up saved data beforehand.

:

Click the Start Button and type cmd
Right-click the result and select Run as administrator
Type this command and press ENTER: bcdedit /set {current} safeboot minimal (ALT: bcdedit /set safeboot minimal)
Restart the computer and enter BIOS Setup
Change the SATA Operation mode to AHCI from either IDE or RAID
Save changes and exit Setup and Windows will automatically boot to Safe Mode.
Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
Reboot once more and Windows will automatically start with AHCI drivers enabled.

http://support.thinkcritical.com/kb/articles/switch-windows-10-from-raid-ide-to-ahci
 

ryan646

Distinguished
Dec 15, 2008
76
0
18,630
0
Adding M.2 drives disables some of the sata ports

You have to check your specific motherboard's user guide to see which ones specifically. All I had to do unplug the sata from the disabled port and plug it into a non disabled port. And now my hdd shows up again with all data intact.
 

ryan646

Distinguished
Dec 15, 2008
76
0
18,630
0


This is the next step I need to take since I am not benefiting from RAID, although I am not sure whether it will mess up the windows installation.
 

ASK THE COMMUNITY