[SOLVED] HDD seems to be broken? Please help to diagnose..

Oct 3, 2019
2
0
10
0
Whenever trying to copy/install bigger files (from 20-40 GB) on "New Volume E" HDD in the beginning it's copying the file just fine
with average/normal speed. Then around 20GB it gets slower to around 2MB/s, even in KB range and then just stops.
I tried to check the Local Disk for errors, did defrag it, formatted it several times and it doesn't change it and the same pattern above
happens again, which makes the main storage part of my Laptop (Lenovo Legion Y520) unusable.

Attached some screenshots for your reference:
HD Tune Benchmark Writing error:
View: https://imgur.com/a/lYxgIys

While trying to install a game, it just stops in the middle of it:
View: https://imgur.com/a/5dm7Ydk

Disk Management which shows that the Disk in question (Disk 0, New Volume E) shows no issues:
View: https://imgur.com/a/VxBrGed


Any advice of what I could do, what could be the possible problem here or any check I can do in order to
make it easier for you to diagnose what's wrong would be appreciated.

If I can't figure out what's wrong, will send the Laptop to Lenovo for a check.
 

cherry blossoms

Reputable
Apr 13, 2016
808
41
5,440
184
You can test the drive with Seagates's tools


ST1000lm35 1rk172 :

Other downloads, including drive info / I.D. tools for firmware.


This drive seems to have many complaints. Does Seagate / Lenovo have a firmware update for it?
 
May 9, 2019
22
1
15
2
This family of hard drive easy get error like bad sector, firmware problem or head damaged. I think you can check SMART of it in software. Backup ASAP if you have important data on it.
 
Oct 3, 2019
2
0
10
0
Thank you guys for your answers.

I tried the "Sea Tools for Windows and did the "Fix All Long" test, which got passed:
View: https://imgur.com/a/jFAlTtL


Then I tried to install the game (around 40GB) again, which worked and the game runs normally.
After this I tried to copy some files for another test (200GB) and it got down from 100 MB/s to 2 MB/s,
tried to do it with another file (around 15 GB) and the same happened:
View: https://imgur.com/a/ZuawqHP


I aborted the transfers and restarted the explorer.exe process (in ctrl+alt+delete menu),
then I tried again to copy 200GB of files which at around 10 % went down to 2MB/s - 0KB/s again (almost stopping).

So I guess something is wrong with the HDD and sometimes you can copy files and at a certain point it just stops?
(Everything is just too random)
With this result and all the checks I have done it doesn't seem that I will be able to pinpoint it easily and maybe
just getting a new HDD installed at Lenovo's side would be the best solution...any further ideas of what could be
wrong based on the above is very welcome.
 

ASK THE COMMUNITY