Question HDMI TV capped at 24 Hz

Aug 23, 2019
10
0
10
0
Hello everyone

Two weeks ago, I bought a new Lenovo Y540 (81SXCTO1WW) with a 144 Hz screen. That screen works well, and the switchable graphics (Intel UHD 630 and Nvidia RTX 2060) also work properly. I have updated the drivers via Device Manager (Intel driver is from 4/07/2019) and for the Nvidia driver I have GeForce Experience.

Now I wanted to connect my laptop to my Pioneer TV via HDMI, but there were a few problems there.
  1. The graphics driver for the TV is automatically the Nvidia driver. I can't use the Intel card for this: if I turn off the Nvidia card in device management, the TV just goes black. All settings must also be made via the Nvidia control panel.
  2. The biggest problem is that the HDMI output is capped at 24 Hz, while I can achieve 60 Hz with a different laptop, via the same cable and input. Another input and cable gives the same result. If I try to set 60 Hz manually (through the Nvidia control panel), it will not accept it if it is interlaced. If it is progressive, it is accepted but the screen remains black again. Gaming at 24 Hz is not playable. There is also a lot of screen tearing.
By the way, I can choose the frame rate on my TV when inputting the TV box from the TV provider, this option is switched off when connecting the HDMI from my laptop.

Does anyone knows what the problem could be here? Or has anyone ever experienced a similar problem? The TV is several years old, but the hdmi works perfectly with another laptop (Acer and Asus tested).

Thanks!
 

boju

Champion
Does the other laptop have a 144Hz panel?

Are you trying to setup multiple displays? The laptop's discrete gpu runs through the igpu to work the laptop display. Wondering if 144Hz + 60 is a limitation, have you tried setting laptop display Hz to 60 first?
 
Aug 23, 2019
10
0
10
0
Does the other laptop have a 144Hz panel?

Are you trying to setup multiple displays? The laptop's discrete gpu runs through the igpu to work the laptop display. Wondering if 144Hz + 60 is a limitation, have you tried setting laptop display Hz to 60 first?
Thank you for your reply boju.
The two other laptops have a 60 Hz panel indeed. I do not have the option to limit the laptop display, which is running on the iGPU, to 60 Hz, as you can see here.

There is only the 144 Hz option. Same counts for if I disable switchable graphcis and only enable the RTX 2060, only the 144 Hz option is available for my laptop monitor. (By the way, I don't think the discrete gpu runs through the iGPU, since I can disable the Intel graphics in a software piece called Lenovo Vantage, and also in the bios).

No matter whether I'm expanding, duplicating or only showing on second monitor, the TV's refresh rate keeps being capped at 24 Hz, and the driver used for the TV is the Nvidia RTX driver. It's like it's completely separate from the Intel, since apparently both can be running at the same time.
 

boju

Champion
Thank you for your reply boju.
The two other laptops have a 60 Hz panel indeed. I do not have the option to limit the laptop display, which is running on the iGPU, to 60 Hz, as you can see here.

There is only the 144 Hz option. Same counts for if I disable switchable graphcis and only enable the RTX 2060, only the 144 Hz option is available for my laptop monitor. (By the way, I don't think the discrete gpu runs through the iGPU, since I can disable the Intel graphics in a software piece called Lenovo Vantage, and also in the bios).

No matter whether I'm expanding, duplicating or only showing on second monitor, the TV's refresh rate keeps being capped at 24 Hz, and the driver used for the TV is the Nvidia RTX driver. It's like it's completely separate from the Intel, since apparently both can be running at the same time.
Do you have 60Hz option in Windows resolution monitor adapter? Try set Hz there not intel or Nvidia.
 

boju

Champion
Oh so it is the tv, can't handle progressive 1080p. Check the other laptop is running 1080 interlaced, change it to progressive and see.

Other than that, it's possible Gsync (If an enabled feature) is preventing change. Try disable it.
 
Aug 23, 2019
10
0
10
0
Oh so it is the tv, can't handle progressive 1080p. Check the other laptop is running 1080 interlaced, change it to progressive and see.

Other than that, it's possible Gsync (If an enabled feature) is preventing change. Try disable it.
I do not have gsync on my laptop. The other laptops let the igpu handle the hdmi i/o and automatically use 1080i apparenty, since it runs at 60Hz. As I pointed out in my previous message, my RTX is not capable of doing so.
 
Aug 23, 2019
10
0
10
0
Ok. As pointed out your TV can't do 1080p 60Hz according to it's manual. If you can change it to 1080i for the TV, then that's what it's limited to.
Hello. Allegedly, my HDMI is physically wired to my Nvidia graphics card, so that is probably why it won't run with the iGPU. I don't know if it's true, but it would explain why it won't switch to the Intel graphics.

Secondly, I can't get interlaced signals in my Nvidia configuration screen. It only shows progressive outputs, and it refuses to do manual interlaced ones. I tried to apply 1920x1080 Interlaced, but it did refuse. p

However, in the registry, the 1080i options is available, as you can see:



What could be the problem here?
 

boju

Champion
Yeah, the Hdmi port is wired to the Nvidia card. I was wondering if the laptop display (igpu with Nvidia pass through) was confusing the resolution/hz selections being a 144hz display.

What happens if you make tv the only display?
 
Aug 23, 2019
10
0
10
0
Yeah, the Hdmi port is wired to the Nvidia card. I was wondering if the laptop display (igpu with Nvidia pass through) was confusing the resolution/hz selections being a 144hz display.

What happens if you make tv the only display?
Same result, can only achieve 24 Hz on 1080p, and 1080i won't work. Seems inuitively logical, since my laptop monitor is powered by the Intel graphics, and the tv by the Nvidia graphics, so they have nothing to do with one another.
I can run 60 Hz on 720p though, as described in the manual of the TV. But interlaced signals (1080i, 720i) can't be configured though the Nvidia configuration screen.
 
Aug 23, 2019
10
0
10
0
Are you saying you can run 720p 60Hz from your laptop to tv?
Yes, because it's progressive. And because my tv does support 60 Hz for 720p, but only 24 Hz for 1080p. It does support 60 Hz for 1080i, but Nvidia refuses.
As a proof, here is a screenshot of the settings on my old computer with a 60 Hz laptop monitor:

The PDP-xx7X is the Pioneer monitor, running on 1080i 60Hz through my Intel gpu (from my old monitor), being able to do so through the intel configuration screen (from my old monitor).
My current Nvidia gpu is not able to do that, it gives an error when I click "test resolution", saying that the monitor does not support 1080 interlaced 60 Hz ...

Edit: a difference I noticed though, is that the bit depth is 8-bit on both screens with my old laptop, my new laptop only supports a hdmi output of 32-bits (only choice I have). Does that matter? My new laptop monitor has a bit depth output of 8 bits eigher, through my Intel gpu.
 

boju

Champion
Im not sure why interlaced isn't available, maybe it's because no modern tvs use interlaced anymore and Windows and Nvidia dropped support? Only a guess. I did see interlaced in Windows once upon a time. Anyway, if you can run 720p 60Hz then do that. It's a blessing because 1080i is actually inferior.

 
Reactions: Victortjeuh

boju

Champion
Edit: a difference I noticed though, is that the bit depth is 8-bit on both screens with my old laptop, my new laptop only supports a hdmi output of 32-bits (only choice I have). Does that matter? My new laptop monitor has a bit depth output of 8 bits eigher, through my Intel gpu.
I wouldn't know sorry. Im convinced your best resolution on this Tv is 720p. If want 1080p60hz, get a new tv.
 
Aug 23, 2019
10
0
10
0
Im not sure why interlaced isn't available, maybe it's because no modern tvs use interlaced anymore and Windows and Nvidia dropped support? Only a guess. I did see interlaced in Windows once upon a time. Anyway, if you can run 720p 60Hz then do that. It's a blessing because 1080i is actually inferior.

I wouldn't know sorry. Im convinced your best resolution on this Tv is 720p. If want 1080p60hz, get a new tv.
Well, in fact, the possibility is there (there is an option to select it), but it won't work for this specific monitor on my RTX (it does work on my iGPU of my old laptop).
I have no idea either why it won't work. Interesting video by the way, I'll keep it at 720p for now until a solution is there. The most important reason for the HDMI connection is gaming and movies, so interlacing would be bad indeed. Thank you for your time boju!
 

boju

Champion
You're welcome. I can understand your reluctance to give up the plasma, better picture / pure blacks and next to no input lag when gaming on a lot of these plasma screens. Viera plasma i played on was spot on with keyboard/mouse input. Lcd TVs however, i tried and never again.
 
Reactions: Victortjeuh

ASK THE COMMUNITY

TRENDING THREADS