Question Headphone side stopped working in USB mode

May 18, 2021
30
2
35
0
So, about 3 months ago, may be 2 or 4, don't exactly remember, i bought the Redragon Zeus H510 headset, it was vary recommended to the latin america and they are supposed to be the best in the $50 price range. Those headphones have a removable audio output connector, so there you can connect any 3.5 cable to the system, and the model itself brings a 3.5 to 3.5mm cable and a 3.5 to USB cable. USB features a much better quality and a cleaner sound, at least in my integrated audio card, as well as the possibility of using the brand's audio driver which lets you use 7.1 and other stuff like that. Today i was finely listening some music, not high volume or anything, and i stopped hearing from the left side, I almost entered in panic, but decided to test with the 3.5mm cable and it works there; but the interference sounds and that is too bothering to me and i wont be able to live with these cable. In USB mode, i already searched for audio balance and all seems ok, also replugged everything and tried in other ports with no sucess.

Cable seems strong, the one side silence started when i moved a bit to leave my guitar which i was using to accompany some songs (xd), i didn't applied any force to the cable, i just moved my head like 10 centimeters but cable was still free and wasnt tight in absolute. I accept any idea or suggerence, may it be some compability thing or cable could be broken?

btw, sorry for my english, not my native language
 
May 18, 2021
30
2
35
0
well, i discovered that cable is like loose in usb mode, if i dont move and make some pression in a certain way i can hear trough left side, and it will sound until i move, i guess thats why i got the thing when i moved, should i solder the cable or what?
 

ASK THE COMMUNITY