Question Headphones will not register, can't unplug and plug audio devices.,

Obsidius

Reputable
Oct 14, 2015
18
0
4,510
0
Hey all! Would really appreciate any help with this as it's really been messing with my music production stuff recently.

My PC has recently stopped recognizing audio devices when I put them in any audio jack on the PC. Whichever device is plugged in during startup is the one it users (defaulted to Logitech speakers), and if I plug in headphones after startup they won't register/work despite working on other devices.

Neither inputs work on my PC (it's a desktop, some details below). Recently I got a CPU upgrade that also involved changing the motherboard, but this started happening days after this upgrade. I also believe maybe malware has gotten onto my computer since I let my mate plug her external hard-drive in, not sure if that could be related.

Desktop/Windows 10 PC/Specs:
16gb RAM, GTX970, i7 9700, new motherboard is an MSI B635M PRO-VDH.

Edit: Windows has started registering when I plug them in, and asks to confirm if they're headphones, when I click okay nothing happens! I can't find my headphones in Sound Systems or under Sound Devices, it still only shows the speakers and both monitors.

Nothing changes if I unplug the speakers, then I just can't use either til I restart.
 
Last edited:

Obsidius

Reputable
Oct 14, 2015
18
0
4,510
0
When you change motherboard and CPU you need to reinstall windows fresh and that’s your problem reinstall windows clean format and reinstall
Thanks for replying Mandark :)

New to this, so would a Windows 10 "reset this PC" suffice? If not, I upgraded to Win10 from Win7 and no longer have the code (it was a long, long time ago), would clean installing require somehow backing up everything on an external hard-drive and then doing it from USB?
 
A clean install requires that you pack everything up because you’re going to format the operating system drive. Go ahead and try windows reset. I’ve had bad luck with resets in the past but it might work for you also if you have restore points you might go back to a restore point where it work
 

ASK THE COMMUNITY