Question Headset microphone randomly stopped working

Jan 22, 2020
1
0
10
0
Alright, so I recently purchased a HyperX Cloud Stinger and it was working great until a couple days ago. While I was playing a game my teammates told me that they could hear my keyboard, after which I checked my sound settings to see that my laptop's internal mic was being used. Under the recording tab, there was only the default inbuilt mic and something called stereo mix, nothing about my headset's mic. Under playback devices there was only "headphones", which was weird because one, where were the default speakers, and two, why is it listed as headphones and not headset?

I tried changing to stereo mix as the default device but it didn't work. And yes, I checked both playback and recording tabs for any disabled/disconnected devices, there are none. I've already tried uninstalling and reinstalling sound and audio input/output drivers (almost 20 times now) and troubleshooting. Nothing just seems to be working. Also, I can't open realtek HD audio manager for whatever reason. I've also tried "setting up a microphone" or whatever which is useless because the microphone has to be detected first.

So I'm clueless on what to do next. Any help/advice would be greatly appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS