Question Headset related problem

iMatty

Notable
Mar 14, 2019
1,098
132
890
11
So i have had this headset for a few months now around 4 ish months.
So i noticed that whenever i turn off my pc and come back the next day, the LED on the headset doesn't work.
Its a razer kraken 7.1 V2 even though its detected by the pc and it works and everything.
My question is, whenever i go to device manager there is always that yellow triangle on HID-compliant headset and i have to disable it and reenable it for my headset to work, the error is code 10 or something, then after that my headset shows in my razer synapse or w.e
And the 2nd problem is, whenever am playing any game and am in a discord call, i get a 10 sec freeze and the sound completely goes then comes back and lags my pc for a few secs and it keeps happening.


Any suggestions are welcome.
Thank you in advance!

EDIT:
forgot to mention what i tried, i tried to reinstall and uninstall synapse didnt fix it
tried to manually update the device and it says its up to date.
Unplug and replug again
Restarted my pc few times
changed the USB to a 3.0 USB didnt do anything.
And also my sound is gone unless if i go to task manager and end the kraken helper process or what ever.
 

Mandark

Distinguished
run the windows troubleshooters regarding sound and audio. see what it turns up. make it fail like you described and run the troubleshooter, just for grins and giggles and post back that it tells you.

Take a look at Windows Reliability History and post back that too. Also look at Windows Events under Event Viewer and see if anything stands out about audio problems, app crashes, etc..
 

iMatty

Notable
Mar 14, 2019
1,098
132
890
11
It keeps telling me to disable enhanced audio or something, problem is its already disabled
2nd thing is, when the lag happens the sound icon on my task bar goes to red and i noticed when it goes to red it trys to switch between my headset and the monitor even though my montior does not have any speakers or whatever and also i disabled everything else beside my headset.
 

Mandark

Distinguished
I have always had bad experiences with Razor Synapse software. I generally rely on MS drivers for their KB so it isn't intrusive and annoying. Are there generic drivers you could use from MS perhaps?
 

Mandark

Distinguished
well no, you would not be able to customize without their software. did it used to work? maybe a system restore to a point where it worked properly? if they all work on other pcs then it's probably a windows or driver issue
 
Apr 22, 2019
4
0
10
0
I have the exact same headset, i never used synapse and never had any probleme like you do... you should really try without it and keep us posted
 

fmalexandru03

Prominent
Aug 13, 2018
32
0
530
0
Right click on windows icon, go to device manager, right click on headset that has that triangle on it, disable it and then enable it. It works with Hyperx Cloud Pro II Gun Metal.
 

ASK THE COMMUNITY