Question Headset shows up in Device Manager but not in Playback Devices

Feb 11, 2021
1
0
10
0
This is a problem that has been going on for me on and off for a while. Running Windows 10 and using SteelSeries Artcis 7 Headset for a while with no issues. One day after a restart It no longer shows the headset under playback devices. Not as disabled or disconnected just gone. The headset shows up in both device Manager and shows as connected in the Steel Series Engine as well as the light on the USB dongle working and connected. I have played around with a lot of things trying to get this to work and at times have only made it worse losing the ability to see any connections including my normal speakers. When I first had the issue I tried System Restore to before the problem began with no change. I have tried full clean reinstall of the drivers and SteelSeries Engine and restarting the Windows Audio Service. I tried uninstall and reinstalling Realtek audio drivers.

I have tested the headset on another device and it works as designed no problems there making me believe this is a software issue and not a hardware one. When it does decided to work it seems at complete random its different every time and work perfectly until the computer is restarted again.

Google for help with sound issues is a nightmare of beginner advice like make sure you device is plug in so I'm really hoping you guys can help me with this. Thanks in Advance.
 

Colif

Win 10 Master
Moderator
If they are wireless, they don't use realtek. Its only for analog or digital connections. It has nothing to do with USB.

Do you have latest version of Steelseries Engine 3

Do they show in settings/system/sound as an output device?

which version of win 10?
right click start
choose run...
type winver
and press enter
current is 20H2
 

ASK THE COMMUNITY