Headset stoped working in Win10 (headset is working in other devices)

Feb 6, 2019
2
0
10
0
My headset (speakers with mic) have one plug and it´s devided to two (green and pink) plugs. They are connected to the front panel of PC. They were working well before and then suddenly they stop working. Noticed that speakers alone works, but when I plug in the mic then the speakers are dead too.
From backpanel plugs (integrated in motherboard) they work better, but mic is cutting the sound. I checked from control panel and seems there is somekind recognizing problem, sometimes Win finds them, but most of the time it doesn´t. Don´t know has there been some windows updates automatically before this occured. Can unactivated windows affect to this?
Any hints how to fix this? Is this purely driver issue? Motherboard is MSI B450 Gaming Plus.

Thank you for help!
 

doolittle

Distinguished
It is common for windows 10 updates to cause problems exactly like this, so yes you are on the right track - remove all your audio devices from the device manager and on reboot reinstall the latest drivers from the manufacturer. Usually this fixes it right up.
 
Feb 6, 2019
2
0
10
0


Have to try this. I re-installed all drivers, but I wasn´t remove them from device manager before.
Thank you!
 
Mar 23, 2019
3
0
10
0
Sorry to necro but by remove, y'all do mean uninstall? I'm also having a problem with my computer recognizing headphones and I'm... kind of nervous about uninstallation. Would I have to search for the devices to reinstall them after uninstalling and rebooting?
 

ASK THE COMMUNITY

TRENDING THREADS