Question Heatsink slight rattling?

May 21, 2022
28
0
30
0
I have the Z590M Gaming X. It’s brand new. I noticed that the bottom heatsink below the cpu, which covers the additional m.2 connectors for SSD. Is slightly rattly.

I don’t know if I can tighten it since my screwdriver just doesn’t seem to be able to go more and I’m afraid of going too hard.
Is this ok?
Thanks.
 

Darkbreeze

Retired Mod
It should not be rattling. If it is, then it is likely not installed correctly, possibly not latched in at the other end or something. I'd take out the graphics card, then remove the heatsink, assuming you are talking about the heatsink for the M.2 drive directly below the CPU socket, and check to see that it is actually installed correctly. Is there an M.2 drive installed in that M.2 slot? Did you remove the plastic covering the thermal compound on the underside of the heatsink if you installed an M.2 drive there? Gotta be some reason, because it should not be able to rattle.

Might want to simply leave the heatsink OFF temporarily and then recheck it to see if it's still rattling, because maybe it's not actually the heatsink.
 
May 21, 2022
28
0
30
0
It should not be rattling. If it is, then it is likely not installed correctly, possibly not latched in at the other end or something. I'd take out the graphics card, then remove the heatsink, assuming you are talking about the heatsink for the M.2 drive directly below the CPU socket, and check to see that it is actually installed correctly. Is there an M.2 drive installed in that M.2 slot? Did you remove the plastic covering the thermal compound on the underside of the heatsink if you installed an M.2 drive there? Gotta be some reason, because it should not be able to rattle.

Might want to simply leave the heatsink OFF temporarily and then recheck it to see if it's still rattling, because maybe it's not actually the heatsink.
Ok my bad. It’s actually not rattling exactly. It’s just easy to wiggle when you touch it with ur fingers. There is no rattle at all. I have no m.2 installed.
 

Darkbreeze

Retired Mod
Then yes, it's probably normal for it to not be 100% locked firmly in place. So long as it's fastened down etc. it probably WILL have a small amount of movement without being bound to the top of a drive via it's adhesive thermal pad. Still might want to take it off and take a look just to make sure that the other end, opposite end from where it screws down, is actually locked into place in whatever fashion that board uses to retain the end of the heatsink. Most of them simply slide into a retention slot and then screw down on the other end. Without a drive under them to provide a slight bit of pressure against the heatsink it is probably that it could have a small amount of movement possible.
 

ASK THE COMMUNITY