Question Hello This is my first watercooling build. I cant for the life of me figure out why my temps are crazy. Rtx 3080 pny and waterblock loop

Nov 15, 2020
8
0
10
0
Rtx 3080 pny idles around 36 as soon as it takes load it jumps to 75. My cpu on the loop is a ryzen 3700x idles around 55. it usually stays where its at and doesnt move. Iv reseated my gpu 6 times now using different screws/ changing thermal pads positions. Im using a lian li distro plate g1 with petg tubing. Someone please help
 
Nov 15, 2020
8
0
10
0
From my understanding the g1 distro plate can run in a bunch of different configs. I unplugged the 4 pin making it run at 100 percent it still climbs high. as for reaseating i have a feeling thats the issue. Iv reseated it 6 times. each time draining my loop it sucks. Iv changed the screw sizes/ took the x plate on and off. Temps are slowly getting better than they were when i first started. I also tried wiping some thermal paste off thinkin i applied to much and that rose the temps so i just added a bit more which helped. it doesnt look like the gpu die is smashing together when i pull it apart.
 
Nov 15, 2020
8
0
10
0
pics of the board itself. attempting another reseat right now. im going to try and change the scews around the x bracket with the ek screws. i originally installed the card without the x bracket and that wasnt working. I installed it back and it helped with idle temps. Just not clocked.
 
Nov 15, 2020
8
0
10
0
and that didnt work....... hitting 67c max still doesnt seem right. i have good flow in the loop no air pockets. nothings clogged. ambient is 72f
 

rubix_1011

Contributing Writer
Moderator
I'm willing to bet its how you plumbed your distro block, but would need to see it without the lighting and more head-on to see if you have a flow conflict.

This seems to be an issue around plumbing and flow direction more than anything else.
 

ASK THE COMMUNITY

TRENDING THREADS