Help!!! $20 "Gaming" Computer is not displaying any thing on screen

N1njaDestr0yer

Prominent
Mar 2, 2017
54
0
630
Best answers
0
Hello There,

I was asking this question because I had recently picked up a $20 PC that was really dusty, but it had a problem of not showing anything on the screen. I've tried doing the basic troubleshooting tactics, but it didn't work... it could be a fault with the motherboard...

(When I found the PC) Specs:

CPU: i3 2100 @ 3.1GHz
Ram: 8GB of DDR3 Ram (2x4 Sticks Crucial)
GPU: Gigabyte HD 6850 1GB GDDR5
HDD: IDK could get PC to work but there were 3 HDD's
MOBO: Gigabyte GA-H61MA-D3V
OS: I Dunno, again PC Has Display Issue...

Again any Ideas or Suggestions?
 

jaslion

Splendid
Dec 17, 2012
6,424
0
25,360
Best answers
926


Remove the gpu, hdd's and 1 ramstick if it doesn't boot try the other. Then try to boot.
Have you cleared the cmos by removing the battery?
What's the psu?
Any beeps, leds,... that show?
 

N1njaDestr0yer

Prominent
Mar 2, 2017
54
0
630
Best answers
0
yes... i've tried all the standard troubleshooting tactics, from taking out the RAM and putting one stick back in, and switching it.... nothing changed the GPU... still nothing, Switched out the CPU and still nothing from the screen... where did I go wrong?
 

N1njaDestr0yer

Prominent
Mar 2, 2017
54
0
630
Best answers
0

no, I have switched the i3 2100 to an i5 3570 (not overclockable one)
and i don't think that the Gigabyte board in there ever came with an option for a speaker for the mobo...

 

N1njaDestr0yer

Prominent
Mar 2, 2017
54
0
630
Best answers
0

nope, no beep code if there was one then i would have heard it go off before it gave full control to the OS... or maybe it does have a speaker but it's just not hooked up...
 

jaslion

Splendid
Dec 17, 2012
6,424
0
25,360
Best answers
926


That board does not support 3000 series chips without a bios update. So I recommend you switch it back to the I3 whilst testing.
 

N1njaDestr0yer

Prominent
Mar 2, 2017
54
0
630
Best answers
0
also, I noticed when I had the 6850 card in (plugged in with 6 pin from PSU i felt to check if the fans were spinning but they weren't... it was covered in dust so i cleaned it but still nothing)
 

N1njaDestr0yer

Prominent
Mar 2, 2017
54
0
630
Best answers
0
no... the monitor i was using works i had another computer connected and it worked fine

 

jaslion

Splendid
Dec 17, 2012
6,424
0
25,360
Best answers
926




So have you put the i3 2100 back in there and tested with the igpu that it has? If that doesn't work try another psu as that could very well be the issue then. Either way it will NOT work with the i5 3570 without updating the bios.
 

jaslion

Splendid
Dec 17, 2012
6,424
0
25,360
Best answers
926


What did you do to make it boot? Do you have another psu lying around to use?
 

ASK THE COMMUNITY

TRENDING THREADS