[SOLVED] (HELP)After a fresh reinstall of windows, all drivers won't work.

Mar 17, 2019
4
0
10
0
I just got this

Dell Venue 11 Pro 5130 10.8" Z3775 1.46GHz 2GB 64GB SSD Windows 8.1 Pro Tablet.

I went to reset the PC so I can send it over to my girlfriend.

It gave me an error saying that files were missing for a recovery, I've always just used a usb windows boot drive to install my windows 10. I installed Windows 10, however during the setup I saw there was no networks found. Then when I got to the desktop screen I saw there was an X on the sound and an X on a Ethernet connection at the bottom left and no battery icon.

I try and install drivers for the network adapter and sounds but just kept getting errors. I kept trying different things until I gave up and reset it back to Windows 8.1 Pro.

From there I kept googling and found out that you must install the drivers for the chipset first before installing any other drivers or they won't install.

I installed the chipset drivers and as soon as it finished it rebooted, The sound X went away and the battery icon appeared, I thought I had fixed it mostly and got excited finally.

However the network drivers still have the X and also still give me the same error that they can't be installed.

"qualcomm atheros driver installation program" was the program I tried to use but got an error saying wrong platform or not right os.

That's as far as I gotten today, I need help trying to troubleshoot this issue. I'm trying to have it sent tomorrow.
 

ASK THE COMMUNITY

TRENDING THREADS