Question [help] boot loop->fixed-> Now no display?

Dec 21, 2020
4
0
10
0
I was cleaning the dust out of my pc, then it got this boot loop, i restick ram, open the clip lock on the Gpu, wiggle and insert it back.. now it dont boot loop anymore, but there is no display on screen, keyboard light is off as well.. I notice the 5v and 12v rgb cable of the Ssd is not inserted, but the usb to the ssd is attached and i l’m worried if this could be the problem ?

Please help
 

Vic 40

Titan
Ambassador
First of al never clean a pc when attached to the power, always take it of so powercable out of the wallsocket.

Can only suggest to breadboard to essential parts and see if it will boot. So motherboard out of the case+one stick of ram in the second slot from the cpu out and if needed a gpu, of course necessary power connectors. Do this on a non conductive underground like cardboard or wooden table.

On easy thing to try before that is a clear cmos.
 
Dec 21, 2020
4
0
10
0
First of al never clean a pc when attached to the power, always take it of so powercable out of the wallsocket.

Can only suggest to breadboard to essential parts and see if it will boot. So motherboard out of the case+one stick of ram in the second slot from the cpu out and if needed a gpu, of course necessary power connectors. Do this on a non conductive underground like cardboard or wooden table.

On easy thing to try before that is a clear cmos.

I did clean it unplugged.. tbh, ive never plugged a mobo before, i’ll have to bring to a tech shop tomorrow.. i have no idea why it went like this.. i did clean the area of the gpu with a slightly damp brush.. could this be a problem?
 

ASK THE COMMUNITY

TRENDING THREADS