Question [HELP] Corsair RAM DRR4 3200 running at 2133. Tried updating BIOS and XMP profile.


Aug 2, 2019
Hello guys and girls, i ll start by first listing out my specs:

and ryzen 5 2600x
corsair vengeance lpx
b450-a pro (supports 3200)
rtx 2070
650w power supply
On the ram I can see 16-18-18-36 which I guess are the XMP profile settings needed. It also mentions 1.36V

Backstory: I noticed my pc glitching (pressing space randomly or showing me the options of right-click on the desktop while I was watching Netflix and not pressing anything) so I thought I should check my cpu temps.
In GTA V i had 90Celcius after 10 minutes of gameplay. So i removed my CPU fan (the processor came of with it but apparently this doesn't t ruin an amd processor) and changed the thermal paste.
After booting up the setup i saw that my RAM is running at 2133. I tried manually setting it to 3200 and using the XMP profile but none worked. I updated my BIOS to the latest version (excluding beta) and tried both of them again and same thing, it forces it to 2133.

Before it was working with the XMP profile and the BIOS i had so i don t get what the problem could be. Thanks in advance for the help!
Last edited: