Help! CPU temps on new i7 build are at 100c

haasen

Distinguished
May 6, 2009
29
0
18,530
I put my pc together this morning, downloaded Prime95 and RealTemps 3.2.

At idle the CPU sits at 40c and the mb is about the same. As soon as I start Prime95 all 4 cores shoot up to 97-100c.

Even at only 25% utilization the temps are all above 90.

I haven't done any overclock and have a scythe Mugen cooler installed. CPU fan is set at 100% manually.

I used thermal paste --- Tuniq TX-2.

This was my first build so I ready a bunch of articles and scoured Youtube for video on spreading the paste (I used the finger in the ziplock back method).

Not sure what to do. I'm afraid to use the PC!
 

ristush

Distinguished
Aug 13, 2006
12
0
18,510
I would say try to apply it again, remove it with rubbing alchohol. Might've put too much, or didn't set it the heatsink on right.
 

mr_tuel

Distinguished
May 23, 2009
288
0
18,780
I'll have to agree with the HSF fan theory, and make sure all other fans are oriented properly and that you have them in such a way that for every fan that blows in, you have one that blows out (1:1 ratio); or 1 more blowing out than blowing in (3:2 ratio or 2:1 ratio).

Those have worked pretty well for me at least :)
 

haasen

Distinguished
May 6, 2009
29
0
18,530
It's a Scythe Mugen 2 HS. How do I know how much to tighten? I'm afraid of cracking the MB or crushing the CPU. What's the 'right' amount of pressure/tightening?
 
Use your judgement. The fan shouldn't wiggle when you have it secure. You don't want to strip anything, but the screws need to be tight. You won't crush the cpu. When I'm screwing down on the board, I put my hand on the other side to get leverage and avoid a cracked board.
 

TRENDING THREADS