notso

Distinguished
Jan 20, 2013
9
0
18,510
0
I have a desktop computer experiencing intermittent disconnections to the master router when connected over ethernet (see below).



  • Master router: TP-Link Archer C20 AC750
  • Ethernet switch: TP-Link LS105G
  • Slave router: Netgear AC1200 WiFi Range Extender
  • PC motherboard: MSI MPG Z390 Gaming Pro Carbon AC
The desktop PC experiences about 5% packet loss to the master router while connected by ethernet as in the above setup. Plugging the PC directly into the master router via the cable which normally is connected to the switch causes the packet loss to increase from 5% to 40%. When I connect the PC by WiFi to the range extender (which is configured as a slave router with static IP) the packet loss to the master router no longer occurs, so the cables themselves are presumably not the problem. A second PC connected directly to the master router by a different ethernet cable also experiences no issues. To test the packet loss I ran nping for 10,000 pings at 0.5 s intervals with each of the 4 network configurations.

This problem occured once before, but seemingly went away by itself. It appears to be here to stay this time. I have tried giving the desktop ethernet adapter a static IP, turning off all power saving options I can find (both in Windows powe plan settings and in the ethernet adapter properties), installing Intel drivers from the manufacturer's website, and even changing from Windows 10 to Windows 11.

At this point, I suspect the problem lies with the ethernet port on the motherboard. Is there anything else I can try to further confirm the problem, and if the ethernet is the problem, is there anything I can do short of buying a standalone network card for the PC?
 

notso

Distinguished
Jan 20, 2013
9
0
18,510
0
Have only single network adapter enabled.
If you use wifi, then disable ethernet adapter.
If you use ethernet, then disable wifi adapter.
So far it seems to solved the problem, thank you very much.

With relevant adapters disabled and 1,000 pings at 0.5 s intervals:
  • master router --cable 1-> switch --cable 2-> desktop: 0% packet loss
  • master router --cable 1-> switch --cable 3-> extender --wifi-> desktop: 0% packet loss
  • master router --cable 1-> desktop: 0% packet loss
Confirmatory test with both adapters enbaled:
  • master router --cable 1-> switch --cable 2-> desktop: 1.9% packet loss
 

notso

Distinguished
Jan 20, 2013
9
0
18,510
0
So am I. Honestly I assumed that turning off WiFi using the settings tray in Windows 10 or 11 would have properly disabled the WiFi adapter. The fact that I've only had this issue recently makes me wonder if a recent update changed this behaviour.

Regardless, I know to check it myself in the future, and I have marked your solution as correct.
 

gggplaya

Distinguished
So am I. Honestly I assumed that turning off WiFi using the settings tray in Windows 10 or 11 would have properly disabled the WiFi adapter. The fact that I've only had this issue recently makes me wonder if a recent update changed this behaviour.

Regardless, I know to check it myself in the future, and I have marked your solution as correct.
I would go into device manager and actually disable it properly. Or remove the physical antennae from the motherboard.
 

ASK THE COMMUNITY