• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Help, game crashes on startup everytime

Jan 4, 2017
7
0
1,510
0
*Specs Below* So a couple days ago I used the GeForce Experience application to update to the newest driver (I already had a driver before this that worked for Fortnite). But when I did upgrade to the newest driver Fortnite started immediately crashing every single start up. So then I learned about the DDU process and getting the drivers from Nvidia's website. So I did that and got the newest driver directly from their website and it still crashed. So I did the same DDU process but this time got the one before the newest one which I was using before and it STILL freezes then crashes my whole screen. I always restarted my pc when I installed the new drivers directly from their website, not the GeForce Experience thing, but it still doesn't work. Could there be a driver that's better than the other drivers? Does anyone have a driver recommendation? This is all new to me PLEASE help.
*Specs*
i5 6600
GeForce GTX 1050ti
Asus Z170M-E D3
Corsair 750x (enough power)
 

bigsmilingbear

Upstanding
Mar 7, 2018
143
0
210
24
now you learn that "latest" driver isn't the best driver.
try downloading driver 390.77 and do the DDU process again.
try reading drivers feedback from few sites before actually installing the drivers. if you have to update, check for "latest stable driver" instead.
 
Jan 4, 2017
7
0
1,510
0


Yes this worked, lesson learned. Thanks man.

 
Jan 4, 2017
7
0
1,510
0
MERGED QUESTION
Question from Abnormally Intelligent : "PC Crash Help"







Yes I have done that with multiple Nvidia drivers using the DDU process which completely erases all the drivers from your gpu and then I installed the different drivers from Nvidia.com using a clean install using the custom install option. Right now I have the newest driver but it still doesn't work.
 

Similar threads