Question [HELP]GTA V FPS DROPS Low CPU & GPU Usage. ALL other games run fine

Oct 30, 2020
3
0
10
0
When running GTA V my fps hover around 90-55 (75hz monitor so i really notice when it goes below 75fps), with medium-high settings at 1080p (I've tried all settings and still the same).
The fps drops out of nowhere, all the way down to 40 sometimes.
The CPU usage is always below 35% and GPU around 65-30%.
Its very annoying as every other game (even recent AAA Titles) can run fine 120+ fps Ultra settings.
I've tried reinstalling, lots of settings, the epic games version, driver settings... and nothing seems to do anything. Temps are fine.

PC Specs:

AMD Ryzen 7 2700X
AMD Radeon RX Vega 56 8gb
16GB RAM DDR4 Crucial Ballistix (2x8GB) 2800mhz CL14
120gb SATA SSD
1TB HDD 7.2K RPM (the game is installed here)
PSU: Corsair CX650M

Thanks.
 
Last edited:
When running GTA V my fps hover around 90-55 (75hz monitor
Lock the FPS to 75. (or even lower if you have to)
GTA has crap coding that stops all other threads from running when the main thread is running too fast. The symptoms range from missing graphics, that are made by secondary threads, to heavy stutter and even freezing when the secondary threads are stopped long enough for the main thread to run out of data.
 
Oct 30, 2020
3
0
10
0
ram usage? make and model of the psu?
PSU: Corsair CX650M (80+Bronze 650W Modular)
RAM Usage: 6.4GB-8.5GB
Lock the FPS to 75. (or even lower if you have to)
GTA has crap coding that stops all other threads from running when the main thread is running too fast. The symptoms range from missing graphics, that are made by secondary threads, to heavy stutter and even freezing when the secondary threads are stopped long enough for the main thread to run out of data.
When i lock the FPS (with V-Sync or RivaTuner) all it does is lose all the extra FPS while having the same FPS drops.
I could lower my refresh rate, sure but i didn't buy this setup to run it like my old PC.
Also Enabling MSAA makes the FPS drop way lower in certain parts of the map, to like 28.

There isn't any visual glitches like missing parts of the map , but i've noticed that shadows have a decent resolution only when im like 3 meters close around the player. The anisotropic filter setting doesn't work either (the gpu driver is not interfering).

i made a vid showing how changing most video settings wont improve FPS and MSAA lowering FPS:
View: https://youtu.be/lNFw5qHRqoE

(refreshrate is set to 74 because its an oc'd monitor and thats as high as it goes, i said 75 to simplify).

Thanks and sorry for the delay in responding.
 

ASK THE COMMUNITY