[SOLVED] HELP! Half a year with an oddly behaving PC.

Sep 26, 2020
3
1
10
0
About 6 months ago I was loading into a GTA 5 online game when my power went out. When I rebooted my computer it was full of broken drivers and half working programs. After re-installing just about everything I got my pc working again. Kind of.

For the past half year most modern AAA games have been plagued with strange errors I'll try to explain.

Specs:

Asus tuf gaming x570 (wifi) motherboard,
AMD 3700x processor
NVIDIA RTX 2070 Super.
EVGA 500 Gold PSU

Most of the errors I see are in modern AAA game titles. Most of the glitches are strange stuttering's in graphics that happen regardless of graphical settings. Lower detail on distanced objects. Screen tearing despite v-sync being enabled(GTA V only. This also disappeared after a while) and most recently frames dropping to >3 and all Bluetooth devices disconnecting after 5 mins of online gameplay (Wreckfest only). I suspect this is a hardware issue due to me re-installing every possible driver on my computer. Any help would be appreciated in helping to solve this issue! If you need additional information don't be afraid to ask.
 
Sep 26, 2020
13
2
25
1
Unplug everything, turn off your powersupply and take out cmos battery for about a minute or 2. Plug everything back and see if the issue is still going on. Also, you could've corrupted your OS.
 
Sep 26, 2020
3
1
10
0
Yeah thermals are all fine and usage isn't acting abnormal. I have 16gb of g-skill trident 3400 Mhz. I have a 500GB ssd. Maybe it's the power supply. I'll try and see if I can fins one to swap out.
 
Sep 26, 2020
13
2
25
1
Unplug everything, turn off your powersupply and take out cmos battery for about a minute or 2. Plug everything back and see if the issue is still going on. Also, you could've corrupted your OS.
 
Sep 26, 2020
3
1
10
0
Unplug everything, turn off your powersupply and take out cmos battery for about a minute or 2. Plug everything back and see if the issue is still going on. Also, you could've corrupted your OS.
Hey! I tried the battery and so far it seems to have worked! Thank you so much I've been struggling with this problem for a while now. Next time I'll make sure to come here first.
 
Reactions: overclockertoov

ASK THE COMMUNITY

TRENDING THREADS