Help. I just built a new NZXT h440, no optical drive, msi motherboard... It won't let me connect to the internet b/c i need dr

TeaGarden

Commendable
Mar 26, 2016
6
0
1,510
0
New NZXT H440 build, no optical drive, no internet connection possible until drivers loaded. I have loaded necessary drivers onto USB drive, please someone explain exactly how I get these drivers off of the USB into my new computer build. Thanks.
 

TeaGarden

Commendable
Mar 26, 2016
6
0
1,510
0
Windows 10, the OS IS reading the USB just fine, I've just never done this before. I'm first trying to get my VGA and LAN drivers in order for my motherboard (MSI z170a sli plus). I just hit 'extract all' ?
 
List the configuration of the system, all hardware.

You need to find the EXACT internet connection settings:
GET the settings from the internet provider.
Go into the internet setup and manually configure the settings.
What TYPE of internet? IPV4? IPV6? Or what?
DHCP, yes or no?
IPV (4) or (6) address?
Subnet mask?
Default Gateway?
DNS Servers?
IP adress?

Once the settings have been configured, it will probably work just fine.
 

lepermessiah

Honorable
Feb 6, 2013
107
0
10,710
6
Depending on how the drivers are archived, there should either be an installer (.exe) or other compressed archive (.zip, .rar, .cab, etc). Either run the installer directly or extract the archive to a folder and execute the installer after it's unpacked. If there is no installer in the archive (there should be) you will have to manually install the drivers through Device Manager.
 

TeaGarden

Commendable
Mar 26, 2016
6
0
1,510
0
So, I extracted the first zipped driver folder onto my new computer - in this case it's the VGA drivers (my monitor currently not at correct resolution.). Now I'm looking at an unzipped folder "WIN64", when I open that folder I see many more... 'Display Audio', 'Graphics', 'Lang', 'X64', *autorun (this one shows a gear symbol), 'installation_readme' (txt file), 'mup', 'readme', 'setup' (application file) aand 'setup.if2'. Do I click either 'autorun' or 'setup' ? Thaanks
 

TeaGarden

Commendable
Mar 26, 2016
6
0
1,510
0
So I just clicked 'setup' (application file) for the MSI intel vga drivers, and my computer said "this computer does not meet the minimum requirements for installing this software". -.- I'm going to try the LAN drivers now instead...
 

RCFProd

Champion
Herald
List which motherboard you have to we can give the right information, we can't do too much with what you've given us so far. Basically, either you get to do a BIOS update that will install what you need including internet, or you need to do it by software. We need to know which motherboard you have.

Edit: LAN Drivers is what you need for ethernet obviously.
 

TeaGarden

Commendable
Mar 26, 2016
6
0
1,510
0
BTW, if it matters, this is my build - H440 case, MSI z170a sli plus mobo, Windows 10 64 (from flash drive), i5 6600k, 16gb 2400 speed geil ram, 480gb ssd.
 

TeaGarden

Commendable
Mar 26, 2016
6
0
1,510
0
OK. The LAN drivers worked anyway, at least I'm connected to the internet now. If i didn't explain it clearly, I did go to the MSI support site and downloaded the VGA drivers for my mobo right from them, so I'm not sure why that wouldn't have worked. I will, as suggested by leppermessiah, read the installation txt file and hope it sheds some insight. Once I got connected to the internet, windows started many update downloads; the screen resolution just fixed itself, so win. Thanks for your replies so far, I hope it all makes sense from here on in. I still need to do something with my liquid cooler (corsair h115i) so that it can utilize corsair link software.
 

ASK THE COMMUNITY