Question Help! I switched cases and changed MOBO and now my PC won't post!

cvLowe

Commendable
Apr 26, 2017
9
0
1,510
0
TL;DR: I switched from one case to another and now my PC won't POST

Current Specs:
Mobo: ASUS ROG Strix z390-E gaming
CPU: i7-8700k
CPU Cooler: Corsair H100i
RAM: 32GB (4x8GB) Corsair Vengeance Pro RGB 3200
GPU: EVGA RTX 2080ti XC Ultra
PSU: Corsair RM850x
Drives: 1 samsung 860 evo SSD (Boot) and 2 seagate barracuda 2TB HDDs
Chassis: NZXT H510i

Recently I've come home from college and on the drive back I decided that my Thermaltake View 71 RGB was not ideal for transportation between home and dorm, so I ordered an NZXT H510i to move my components into when I got home.

When I first got everything from the View 71 into the H510i, the front panel power button wouldn't do anything but make the LEDs on my rog strix z370-e mobo reset. I took out the CPU and noticed that quite a few pins on the mobo were bent, so I tried to realign them and broke a couple pins.

Fair enough... I went to the local Best Buy near my parents' home and picked up a brand new ASUS ROG Strix Z390-E and came back and completely rebuilt the system with the new motherboard inside of the H510i. Upon trying to boot. the light on the AIO will flash for a split second, the cpu cooler fans will twitch, and the LEDs in my RAM light up, as well as the LEDs on my mobo. After that, nothing happens, no fans spinning, no POST, no signal to monitor. It just stays like that. I have no idea what the problem could be at this point and it's the only Intel desktop in the household, so no other parts available for troubleshooting purposes. Any help would be very greatly appreciated.

Solutions Attempted:

Reseating CPU
Reseating CPU Cooler
Booting with only CPU, CPU Cooler, one stick of ram, and my SSD boot drive
Reseating GPU and RAM
Unplugging and re-plugging all connections to PSU

Everything I have attempted has yielded the same result: RAM Light, CPU Cooler fan twitch, AIO Light brief flash, no POST or signal, no LED indicators on MOBO

I don't have mobo speakers to use, so i can't hear any of our beloved beeps ):

Thank you for taking your time to read this and try to help me, I am very sad and desperate for this to work. ):
 

ASK THE COMMUNITY

TRENDING THREADS