Help is cpu dead?

Jul 27, 2018
3
0
10
0
So I was playing a game and all of a sudden my pc just shut off and wouldn’t boot back up. I’ve had this pc for over 4 months now. I’ve done some testing to see what might be the problem but I just wanted to be a bit more sure that it’s my cpu thats the problem. I tested my psu if it is working properly and it is, removed gpu to see it pc was receiving enough power, removed ram and tried different ram slots. My motherboard still seems like its working because when I don’t connect the 8 pin my pc would boot up perfectly but you know show no display. And if I would connect the 8 pin it wouldn’t boot back up and not even the fans would spin.

Specs:
i5 7400
rog strix b250i gaming
Corsair vengeance rgb ram 16gb
Msi gtx 1050 ti
240 gb ssd
1 tb hdd
Psu Corsair 550w
 
most cpu are heat killed or voltaged killed. (to much voltage when overclocked. ). most new power supply are made not to backfeed if they fail. you may have power supply issue or the vrm failed on the mb. the no post is a dead short feature of the power suppyl and mb to keep other parts from frying. start with no gpu and a test power suppyl see if onboard video will post if there no post rma the mb.
 
Jul 27, 2018
3
0
10
0
Sorry for the late response I took out the gpu to see if it would post with the onboard video but it didn’t. Also, tested the power supply with a paper clip with a fan connected and it turned on just fine. So like you said the vrm failed on the motherboard.
 

ASK THE COMMUNITY

TRENDING THREADS