Question Help me diagose issue with non posting B450-I AORUS PRO WIFI (SOCKET AM4) MINI-ITX

Feb 13, 2021
2
0
10
0
Specs
Ryzen 5 3600
B450-I AORUS PRO WIFI (SOCKET AM4) MINI-ITX
Corsair Vengeance LPX 16GB 3600mhz DDR4
Palit GeForce RTX™ 3070 GamingPro
Samsung 860 EVO 1TB 2.5 SSD 1TB

Hello,
Hoping someone can help - have read through the sticky with common things to try for non-posting systems.

This build has been running fine since November and booted up first time when I put it all together.

The CPU was getting slightly hot (still acceptable 75 – 80) while gaming so yesterday I decided to try and install a Noctua NH-L12S Low Profile cooler.
On removing the original cooler, it pulled the CPU with it and bent two of the pins slightly – to the extent the CPU wouldn’t slot back into the AM4 socket. I carefully bent them back after watching a video online and it now slots in fine. A small amount of thermal paste ended up on the pins and AM4 socket – I’ve cleaned that small amount with a cotton bud.
However, the PC now won’t boot. I have tried with the original cooler and the new one (some concern that the new one may have needed to be too tight) but neither lets me post to BIOS. The monitor reports no signal.
Other notes / things I’ve tried:

  • Cleared CMOS – removed battery for a hour
  • Re-seated RAM
  • Tried with just one RAM stick
  • Disassembled all components and re-assembled from scratch
  • All of the fans CPU, case fans and GPU all spin. GPU’s LEDs light up correctly
  • Weirdly, the case power on button turns the PC on, but then neither it nor the reset button work to turn off or reset. Only way to turn off is to remove the power lead
Main questions are:
What to try next? Thinking local PC store and test another AM4 processor to confirm whether it’s that?
Is there anything I can try myself?
I’ve included an image of the processor PINS and the AM4 socket for reference.
Any help greatly appreciated – kicking myself for tinkering now..

https://pasteboard.co/JOctgTS.jpg CPU

https://pasteboard.co/JOcu1JY.jpg CPU

https://pasteboard.co/JOcuihl.jpg SOCKET
 

ASK THE COMMUNITY

TRENDING THREADS