[SOLVED] Help me get this RX 570 back to life

Oct 30, 2018
17
0
10
0
Hello guys, i bought a used RX 570 Gigabyte 4G and im sure there is something wrong, like used for mining, as i cant install the drivers giving me error 43 from Windows, but when i use the ATIKMDAG patcher its fine, but after playing a Little with games it crashes

MY PC:
ASUS PRIME A320M-K
Ryzen 5 1400
12GB RAM
Windows 10 64 bit Pro
 
Sounds like it has a custom bios, which will cause the driver to not install without pixel patcher being run each time the system is rebooted. You will need the stock bios and flash it. Sort of a tricky process and can sometimes "brick" the GPU. Out of the 30+ times I've flashed an AMD GPU bios (for mining), only about 4 times it "bricked", but each time I was able to recover by forcing a bios flash using Windows command prompt.

Try to find the original bios here - https://www.techpowerup.com/vgabios/
 
Oct 30, 2018
17
0
10
0
Hello i tried with the original bios found there in techpowerup and ATI flash gives me the error : "different subsystems ID" or something like that, my pc is in spanish and im trying to translate what i can
 
Install and run GPU-Z and find out the memory type (Hynix, Samsung, Micron, etc.).


You might have to run the pixel patcher and have a driver installed for GPU-Z to correctly read your GPU's memory.

I would also ask the seller you bought the card from is they have the original bios available to send you.
 
Do you have a spare GPU to use for a display output in case you brick this GPU? If not, then you might want to refrain from flashing the bios.

The bios on TechPowerUP is for Hynix, but you really need a driver installed because I've seen it say one thing without a driver and another with a driver.
 
Oct 30, 2018
17
0
10
0
Do you have a spare GPU to use for a display output in case you brick this GPU? If not, then you might want to refrain from flashing the bios.

The bios on TechPowerUP is for Hynix, but you really need a driver installed because I've seen it say one thing without a driver and another with a driver.
i have another gpu here lying around
 
Oct 30, 2018
17
0
10
0
Do you have a spare GPU to use for a display output in case you brick this GPU? If not, then you might want to refrain from flashing the bios.

The bios on TechPowerUP is for Hynix, but you really need a driver installed because I've seen it say one thing without a driver and another with a driver.
ill install the driver then
 
Oct 30, 2018
17
0
10
0
so i fhashed the bios of the RX 570 from the website of Gigabyte and now the driver installed without problems (without using the patcher) ill test a game and tell you if it crash
 
Oct 30, 2018
17
0
10
0
MY game the forest crashed (the fastest game to crash in my computer) after flashing bios and installing drivers, i dont get error 43 anymore but it crash
 
Oct 30, 2018
17
0
10
0
I think i solved it, i underclocked it and now it doesnt crash, so basically the solution was to flash the bios from webpage manufacturer and underclock the GPU
 

ASK THE COMMUNITY

TRENDING THREADS