Help! "Memory write" error or driver problem?


Nov 12, 2006
I just built my new system a month ago and have been having some issues. During the level/map change loading in Farcry, I have been getting crashes/ freezes. The first time this happened the blue screen appeared right when it seemed to be about finished loading the next level.
The blue screen had: STOP: 0x0000007F

I restarted and tried it again with the same result. When windows came back, the error report showed:

The following files will be included in this error report:
" " " " " " \sysdata.xml
Error signature:
BCCode:7f BCP1:00000000 BCP2:00000000 BCP3:00000000
BCP4:00000000 OSVer: 5_1_2600 SP:2_0 Product 256_1

The technical report browser showed:
Problem cause by Device Driver

However, I turned the computer off for a few hours and the game was working again and the level loaded. Then, another error occurred during another loading zone. This time, there was no blue screen. I was able to exit the game and saw this error message:

Critical Exception:
Code:0xC0000005 Address: 0x001B:0x4FE759B2
Attempt to write data to address 0x00000038. The memory would not be "written".
followed by a Call Stack Trace.

The game can run, but these errors reappear. Are these errors in any ways related? Can anyone point me in the right direction?

In another problem(probably unrelated), I got "The nv4_disp display driver has stopped working normally" while playing the Ship, a retail mod of Half Life 2. I've also gotten freezes during in game loading zones in Half Life 2, where the hard drive light blinks for a while but stops.

Thanks for any and all help.


A good first step is to make sure your memory is working under normal conditions by running memtest86+ through at least a few complete cycles without any errors.
A more stringent test is to run Orthos (dual PRIME95) stresstest successfully for at least an hour or so.