[SOLVED] Help! My cyberpunk is unplayable completely blurry!

aayushkhajuria2842

Honorable
Nov 24, 2015
13
0
10,520
1
I have played cyberpunk 2077 for 9.1 hours and after maybe 8 hours I have started to get this problem where my whole game is so blurry nothing is clear but I have noticed that this occurs usually only in darker places in the game and the game was fine before it suddenly got so bad.


Watch the recorded clip to see the extent of blur. .

View: https://youtu.be/DrGvIafpn4o

I have included the in game settings in the uploaded video.
Also My PC Specs are
AMD Ryzen 5 3500X
NVIDIA GeForce RTX 2060 6GB (Gigabyte)
16 GB Single-Channel Corsair Vengence 3000 mhz RAM
Gigabyte B450M DS3H WIFI-CF (AM4)
960GB KINGSTON SA400S37960G SSD

I am posting here for the first time so if I have missed any details that I should have mentioned then kindly ask me for the same.
Kindly help me because my game has become unplayable right now because in some missions set inside buildings the blur is even worse than u can see in the video.

Thank You.
 
Well, yeah, I would try reinstalling the game.

Just to be sure, I would first try running SFC and Malware scans to make sure the problem isn't caused by system file corruption or malware.

Follow these instructions exactly for the SFC scan. https://support.microsoft.com/en-us/windows/using-system-file-checker-in-windows-10-365e0031-36b1-6031-f804-8fd86e0ef4ca

Good free Malware checking tool. https://www.malwarebytes.com/mwb-download/

If you're on W10, I also recommend updating to the latest 20H2 build, it's got some fixes in it and is less prone to crashing than the previous 1909 build.
https://www.microsoft.com/en-us/software-download/windows10
 
Have you tried turning motion blur completely Off?

Also, are you updated to the latest game update, which is 1.04 I think?

And do you have the latest GPU driver? Try reinstalling it as well even if you are, it could be corrupted.

For possible driver corruption, I recommend using DDU in safe mode, restart the PC, then install the driver from desktop.

This looks more like graphical artifacting than typical blur, are you running an OC on your GPU or CPU? If so, try reverting to stock settings.

It's also not ideal to run single channel RAM with a Ryzen. The sweet spot is typically at least 3200 and dual channel. This can lower the latency between the CPU and RAM. However this is more often related to hitching and stuttering due to the frame drops it causes.
 
Last edited:

aayushkhajuria2842

Honorable
Nov 24, 2015
13
0
10,520
1
Have you tried turning motion blur completely Off?

Also, are you updated to the latest game update, which is 1.04 I think?

And do you have the latest GPU driver? Try reinstalling it as well even if you are, it could be corrupted.

For possible driver corruption, I recommend using DDU in safe mode, restart the PC, then install the driver from desktop.

This looks more like graphical artifacting than typical blur, are you running an OC on your GPU or CPU? If so, try reverting to stock settings.

It's also not ideal to run single channel RAM with a Ryzen. The sweet spot is typically at least 3200 and dual channel. This can lower the latency between the CPU and RAM. However this is more often related to hitching and stuttering due to the frame drops it causes.
Current State:
View: https://youtu.be/44hvkNE05n0

1) Turned motion blur to off as u can see in the video but still no improvement and this tym recorded a clip in a darker so its even worse cant even look where i am going.
2)And i have no updates available on steam.
3)there was a driver update available and i installed it via Geforce Experience now I have the latest gpu drivers installed but still the problem is same.
4) I have not overclocked cpu or gpu but set the ram to 2923 Mhz
So only Ram being single channel can do such harm to performance ? no such problem occurs in any other games i play GTA 5 , PUBG, COD Warzone and some others games never had such issue in any other game.
Kindly guide me on what can i do.
Thanks for replying
 
What method did you use to update the GPU driver? As I suggested, it's best to remove it via DDU in safe mode, then install the new one at desktop after a reboot.

As I said this very much looks like graphics artifacting though, which is commonly caused by unstable OCs or corrupt drivers. What's confusing here is you first mention the RAM as 3000 MHz, then go on to say it's OCed to 2923. What is the stock rated frequency? I would try reverting to that, as the OC may be unstable.

It doesn't matter if an OC is stable on other games, it can often be the case where one poorly coded game, such as this is, makes it unstable. Just set the RAM to XMP, which will make it run at it's rated speed.

As far as what I said about single channel and low RAM frequency, as I said it's more likely to just add latency, as Ryzen performance is linked to RAM speed. Higher frequency RAM (3200 or more), and the speed that dual channel configuration adds, lessens the latency between the CPU and RAM, which minimizes fame drops and the hitching and stuttering it can cause. It's unrelated to the problem you are having, but a potential problem of it's own none the less, especially when playing resource hungry, graphically intense games.

I also just read that they just issued a patch for the game (1.05) to fix performance problems with consoles and AMD Ryzen CPU PCs with 4 or 6 cores. Yours is 6 core, so you definitely need this update. I can see in your vid at the lower left corner of the screen that you are only patched to 1.04, so I suspect that is the problem. They also mention a ton of blurriness, particularly when Film Grain is applied, so I'd also recommend turning that off (shows as On in your vid). Patch 1.05 may solve that problem though, IF you really want to play with Film Grain on.

Keep us updated. ;)
 
Last edited:

aayushkhajuria2842

Honorable
Nov 24, 2015
13
0
10,520
1
What method did you use to update the GPU driver? As I suggested, it's best to remove it via DDU in safe mode, then install the new one at desktop after a reboot.

As I said this very much looks like graphics artifacting though, which is commonly caused by unstable OCs or corrupt drivers. What's confusing here is you first mention the RAM as 3000 MHz, then go on to say it's OCed to 2923. What is the stock rated frequency? I would try reverting to that, as the OC may be unstable.

It doesn't matter if an OC is stable on other games, it can often be the case where one poorly coded game, such as this is, makes it unstable. Just set the RAM to XMP, which will make it run at it's rated speed.

As far as what I said about single channel and low RAM frequency, as I said it's more likely to just add latency, as Ryzen performance is linked to RAM speed. Higher frequency RAM (3200 or more), and the speed that dual channel configuration adds, lessens the latency between the CPU and RAM, which minimizes fame drops and the hitching and stuttering it can cause. It's unrelated to the problem you are having, but a potential problem of it's own none the less, especially when playing resource hungry, graphically intense games.

I also just read that they just issued a patch for the game (1.05) to fix performance problems with consoles and AMD Ryzen CPU PCs with 4 or 6 cores. Yours is 6 core, so you definitely need this update. I can see in your vid at the lower left corner of the screen that you are only patched to 1.04, so I suspect that is the problem. They also mention a ton of blurriness, particularly when Film Grain is applied, so I'd also recommend turning that off (shows as On in your vid). Patch 1.05 may solve that problem though, IF you really want to play with Film Grain on.

Keep us updated. ;)
View: https://youtu.be/MMS5KtC_fOE

Previously i updated GPU drivers from Geforce experience but now i have uninstalled them using DDU and installed the latest driver again.
Now update for cyberpunk on steam was also available so i installed it too.
Disabled Film grain as well.
after above stated changes there is no difference as u can see in the video.

my Ram is rated for 3000Mhz but its base clock was 2300 something so i used easy tune by gigabyte a software that came in a disc with the motherboard to set Xmp to Profile 1
and changed base frequency to 29.33 so am i overclocking this ram as it was supposed to be a 3000Mhz ram ? and now what i need to do ? Disable XMP profile ? Memory frequency has no option like 23.00 or something near so how do i revert to base clock ? im new to these things so might be asking a dumb question.

also i noticed in the recorded videos the blur or missing textures appear very less as compared to what i am observing actual in game its a lotdarker inside thegame the video capture software is maybe applying increased brightness so these videos look a bit better than actual game.
 
What you're referring to as base clock I believe is actual your MB's base memory frequency. There should be just a setting to enable XMP to let it run at it's rated frequency. No OC should be required to do that. Other than profiles, is there not just an option to set XMP to enabled?
 

aayushkhajuria2842

Honorable
Nov 24, 2015
13
0
10,520
1
What you're referring to as base clock I believe is actual your MB's base memory frequency. There should be just a setting to enable XMP to let it run at it's rated frequency. No OC should be required to do that. Other than profiles, is there not just an option to set XMP to enabled?
So I reset to default via Easytune so XMP got disabled and memory frequency came back to 2133 i was saying wrong that it was near 2300. then i enabled xmp profile 1 via bios and so now xmp is enabled but it is still running at 2133 MHz i have enclosed a pic of its box which says it can run at 3000Mhz
But even after getting back to 2133 Mhz the problem is still the same.
Link for uploaded pics
https://ibb.co/TvkbfpM
https://ibb.co/RDSZFkb
 
I looked in your MB pdf manual and it does say to use Profile 1 to enable XMP. Maybe you hadn't rebooted after resetting it to that, because that should make it run at 3000 again.

Your latest video does indeed show that you are now updated to patch 1.05, so I don't know why the problem still exists, unless of course they rushed the patch without testing to make sure it works on all 4 and 6 core Ryzen AMD CPUs.

Still curious as to why you chose one RAM module to run in single channel when you could have equipped a faster dual channel kit?
 

aayushkhajuria2842

Honorable
Nov 24, 2015
13
0
10,520
1
I looked in your MB pdf manual and it does say to use Profile 1 to enable XMP. Maybe you hadn't rebooted after resetting it to that, because that should make it run at 3000 again.

Your latest video does indeed show that you are now updated to patch 1.05, so I don't know why the problem still exists, unless of course they rushed the patch without testing to make sure it works on all 4 and 6 core Ryzen AMD CPUs.

Still curious as to why you chose one RAM module to run in single channel when you could have equipped a faster dual channel kit?
I am new at building pcs so thats why relied on the dealer from whom i got the pc to pick some compatible parts for me. i had just told him that i want ryzen 5 3600 and rtx2060 the cpu was not in stock so he offered me 3500X and i researched on it a bit to find many people stating that 3500X does not bottleneck rtx2060 or if it does its minimal but that was not true now in most of the games my gpu usage is never beyond 50-60%, cpu usage is 80-90% and fps is lower than what people are getting from rtx2060 paired with higher CPU so i was already not satisfied with build because of the CPU now i know that ram was also not right. i was not on a tight budget so could have bought better Ram and CPU but maybe i was impatient and didnt wanted to wait for these parts to come back in stock at my local dealer. so thats my story.
Dont u think reinstalling the game is worth it ? because the game was fine for intial hours ?
Also what do u think i can do with ram ? should i buy a same 16 gb ram will that make it work like dual channel ? but in that case also 32 gb will be way more than what i need. or should i buy two 8 GB sticks and discard this one ? is it woth it to buy new ram beacuse several articles and videos say the difference in performance between single and Dual is minimal ?
getting better Ram can reduce the CPU bottleneck ?
Also My RAM is still running at 2133 with XMP to profile 1.
I really appreciate the time u are taking to answere my questions. Thank you.
 
Last edited:
Well, yeah, I would try reinstalling the game.

Just to be sure, I would first try running SFC and Malware scans to make sure the problem isn't caused by system file corruption or malware.

Follow these instructions exactly for the SFC scan. https://support.microsoft.com/en-us/windows/using-system-file-checker-in-windows-10-365e0031-36b1-6031-f804-8fd86e0ef4ca

Good free Malware checking tool. https://www.malwarebytes.com/mwb-download/

If you're on W10, I also recommend updating to the latest 20H2 build, it's got some fixes in it and is less prone to crashing than the previous 1909 build.
https://www.microsoft.com/en-us/software-download/windows10
 

ASK THE COMMUNITY

TRENDING THREADS