HELP my gtx 1050 ti has stopped working properly for no reason whatsoever

Feb 6, 2019
5
0
10
0
My nvidia graphics card gtx 1050 ti has stopped working yesterday, my display screen has turned to 800x600 resolution from 1280x1024 which is the default, the nvidia control panel has disappeared when I right click the screen and when I tried to open it from control panel it said:"You are not currently using a display attached to and NVIDIA GPU" even tho that is not true. I tried reinstalling and completely deleting the drivers but it had no affect. When I connected my cable to the integrated graphic card on my computer the display started working normally, I really do not know what to do anymore I tried absolutely everything and it didn't work, also my screen has these horizontal lines just to add. Also to add when I click on advanced settings in the screen resolution it doesn't show the gtx, it shows the Microsoft default display
 
Feb 6, 2019
5
0
10
0

But it barely lasted half a year and it worked properly yesterday, it had no indications of malfunction and it never overheated, when I browsed the internet I saw it as a common problem for nvidias control panel to stop working, I ask if there are any more options for me to try out before I send it to service to get repaired if it can
 

jay32267

Distinguished
As far as options....I don't know any....you may try and post this again and see if anyone else has any ideas....but I really think things are pointing to the card being the problem.

Bad cards DO HAPPEN....I just had to RMA an RTX 2080 Ti. It lasted 5 days.
 
Feb 6, 2019
5
0
10
0

[removed]




What do you mean post this again, sorry I'm so bad with forums(this is my first time actually posting), I'm sorry for your card tho and thank you for your help
 

jay32267

Distinguished
There are a few reasons why I think it's the card.

It seems like the driver is finding fault in the card.
""You are not currently using a display attached to and NVIDIA GPU""

....and this.....it doesn't seem the card is recognized.
"Also to add when I click on advanced settings in the screen resolution it doesn't show the gtx"

This did work
" When I connected my cable to the integrated graphic card on my computer the display started working normally"

....and this is a classic symptom for a failed card
"also my screen has these horizontal lines just to add.

This didn't work
"I tried reinstalling and completely deleting the drivers but it had no affect."

So all those things point me to the card.
 

jay32267

Distinguished
"So I can't do anything to try and repair it? Maybe its the PCI E slot? "
I don't know of anything you can do to repair it.....and as far as PCIe slots.....they usually don't "go bad".....GPUs are more likely to "go bad". It should still be under warranty so I would send it in.
 

ASK THE COMMUNITY

TRENDING THREADS