Aug 29, 2021
1
0
10
0
Hey there!
I have a problem with my Clevo laptop,
It worked good for a long time, now i'm expierencing a, in my eyes, big problem.
When I power on the laptop, the keyboard lights go on, the fans spin but i'm greeted with a black screen.

It's a laptop with the following specs;
4700MQ
16Gb DDR3
GTX 770m

If have tried the next;
  • change ram slots
  • change ram modules
  • repasting the GPU and CPU
  • Use a diffrent SSD
  • Unplug almost every component (RAM, SSD, HDD, WiFi module)
  • Pull out, wait 5 sec and plug the bios battery again
  • Put the GPU 10 min on 200 C in the oven
I just don't get any picture, not even when i plug in the laptop to a external display.

I think its a dead GPU, could i be right?
Do you have any other causes op fixes please let me know.
 

lga1156_ftw

Respectable
Feb 25, 2020
1,289
148
2,390
177
Never seen any of these clevo laptops myself but seen from disassemble videos that you can basically swap even gpu in these models which is very nice.
I see you tried the "oven" method, idk why this sounds so funny
  • Put the GPU 10 min on 200 C in the oven
What is the exact clevo model?

If it wasnt the GPU what was the problem it might be done now, good thing is these arent that expensive. Have you tried to hook up external monitor to the HDMI slot and then power on? There might be key combination required to chnage to external monitor, read from the manual or look for symbols on the keyboard, if you get picture on external its probably that the internal LCD is broken.

If external gives no picture after that, remove main battery and power connector, then press power button for 30-60 seconds just keep holding it, after that just plug in the power connector without main battery and try to power up. This should reset embedded controller.

Check all the USB ports with flashlight to see if any pins look messed up or shorted.

You can also try remove power cable, hold FN+B (keep holding) and with other hand plugin power cable then press power on key. Keep still holding FN+B ,bios recovery menu (this should recover in some cases). Bios recovery mode might be also FN+D try both combinations, fans running full speed "might" be indication your entering the mode.

For usb bios recovery need to know exact clevo model
 

ASK THE COMMUNITY