HELP! My Monitor Turns Off Now and Then

sweetmisery

Distinguished
Jul 5, 2007
9
0
18,510
First off, Im using an hp LCD; and my video card is a GeForce(Palit) 8600 GT.

Last month, one day my monitor wont turn on anymore, it keep saying NO SIGNAL then MONITOR IS NOW SLEEPING. The rest of the computer seems to be working. According to the technician, its the video card. Which tested, is indeed the culprit. They have to send it back to replace the video card(waited 4 weeks).

So I have to use the built-in video in my mobo.

Just last week, the replacement video card arrived. Its brand new, and yes, it works. Except that when playing 3D games, every once in a while, the monitor turns off again. I have to restart the computer manually, afterwhich, it will be fine again.

There are days it wont do this, but there are days where it will after playing games for 1-4 hours. At most, the monitor turns off 3 times in a day. I used some computer hardware check... and it cant find any problem. Even tested the video card to its limits.

Any clue what might caused this? Is this another defective video card? Or a software glitch? I did reinstall nVidia's latest drivers.

Any help will be appreciated!
 

konzserwas

Distinguished
Jan 20, 2008
20
0
18,510
If monitor says no signal it should be monitor's problem. Even if you remove your VGA from pc and connect it to monitor while holding the card it will still recognise that you connected it.
 

sweetmisery

Distinguished
Jul 5, 2007
9
0
18,510
Its an hp LCD. Less than a year old. But when my video card is being replaced, its working well with the built in video. No problems at all. It only happened with the new video card(and the old one).

I just checked the nvidia site, seems like its a firmware problem. Not sure though.
 

kad

Distinguished
Feb 29, 2008
524
0
18,980
Normally when everything is running but monitor saying no signal it is the monitor
But as long as it worked fine on thebuilt in chip on your Mobo then it is clear THE CARD
Before sending the card back doule check and connect your monitor to another PC and see
I'm quite sure it is the card
 

sweetmisery

Distinguished
Jul 5, 2007
9
0
18,510
My PSU is a hec 550.

As I said in my first post, the original card died(after 7 months), same problem. Now that I got the new card, it works but now and then, it shuts down. In the nvidia forums MANY are complaining about this, though most are game freeze/lock... were all using Vista + its the Series 8 of GeForce. Might be that too.
 
G

Guest

Guest
Ive encounter that problems a years ago when i bought radeon 9250......the monitor is turning off when i turn on my pc but the other components are working...
i think your processor speed wont fit on the requirment of the video card.....
 

roope

Distinguished
Jun 17, 2009
1
0
18,510
I've had that problem a lot with my radeons. Usually it helps to get a new, more powerful power supply. If that doesn't work, uninstalling the graphics drivers (catalyst) and installing >3 versions older drivers. that usually does the trick. radeon drivers suck imo