Question Help my PC keeps shutting itself down

Victel

Reputable
Oct 31, 2016
19
0
4,520
1
I bought a 2080 ti but ever since installing it my PC has been turning itself off at random times and I don't know why. I attempted switching PCIE slots, trying the first second and third slot all having the same problem. I've tried connecting different power cords to the GPU with no luck. I've cleaned my PC. I used AIDA extreme and looked at the event logs and it only tells me unexpected shutdown Event ID 6008. All my temperatures seem okay.

My hardware is Rampage V Extreme Motherboard. i7 5960-X, corsair dominator ram and 2080 ti GPU. 1500 PSU

Thanks
 

Phaaze88

Splendid
Ambassador
Common caused of sudden shut offs:
1)Corrupted OS drivers.
What you can try: Healthcheck/chkdsk: https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker
Worst case, you'll have to reinstall the OS. Then again, if you haven't done it in some years, you're probably due for one.

2)Memory corruption.
What you can try: Memtest86 free version: https://www.memtest86.com/
It takes a few hours, so run it overnight. The results should be error-free, with no system hangs or crashes.

3)Loose cables.
Pretty simple one.

4)Unstable overclocks.
Also simple; test without them.

5)Power supply.
You really need another one on hand to test this.
 

Victel

Reputable
Oct 31, 2016
19
0
4,520
1
I bought a 2080 ti but ever since installing it my PC has been turning itself off at random times and I don't know why. I attempted switching PCIE slots, trying the first second and third slot all having the same problem. I've tried connecting different power cords to the GPU with no luck. I've cleaned my PC. I used AIDA extreme and looked at the event logs and it only tells me unexpected shutdown Event ID 6008. All my temperatures seem okay.

My hardware is Rampage V Extreme Motherboard. i7 5960-X, corsair dominator ram and 2080 ti GPU. 1500 PSU

Thanks
I reformatted maybe a month ago, is it possible it has something to do with my new 2080ti that I just put in? I didn't have these problems before I bought it. They started right away when I put it in.
 

ASK THE COMMUNITY

TRENDING THREADS