Question Help needed with blank screen ?

Jul 20, 2021
8
0
10
0
OK so there's a bit to this so I will try and explain it the best I can. I built this system about 10 months ago. Performed flawlessly since new.

Last night mid game I get a massive crash than receive this error code 0xc0000225 which is to do with Windows being corrupted. I tried several times trying to boot with my usb with Windows on it to do a repair couldn't get it to work. Than I lost the ability to get into bios. So I tried removing the nvme drive and put it back in to make sure its seated properly. Than booted in safe mode to try and see if I could get to bios or do anything. Now it won't show anything on the screen. I have removed the cmos battery for a decent amount of time and also turned on and off 4 times to try and get into recovery mode to no avail. Also have a red led for 'boot'.
Thank you in advance!

System specs:
Ryzen 3300x
Asrock b550m steel legend
Rtx 3070 gigabyte oc
Corsair vengeance rgb pro 16gb
Thermaltake 750w psu
 
Jul 20, 2021
8
0
10
0
Yes it is modular and did change out my pcie cable for another one to check. And also did take out a ram stick to check no hood either
 
Jul 20, 2021
8
0
10
0
You may be left with no choice but to remove your motherboard from the case. Perhaps there is a short somewhere in the setup. You could try booting with any front USB ports disconnected from the motherboards external USB header.
Yeah OK, might be my only choice. Seems like the motherboard might of left the chat 😬 only 10months old or so.
 
Jul 20, 2021
8
0
10
0
I am suggesting you try booting outside the case, not replace the motherboard. You can RMA the motherboard if you need to.
Woud it be shorting out even if my fans and mb LEDs come on and gpu lights and fans go on aswell, Plus hdd spinning up and water pump turning on?
Everything turns on and stays on but no screen action on the 3 screens I have tried.
 
Woud it be shorting out even if my fans and mb LEDs come on and gpu lights and fans go on aswell, Plus hdd spinning up and water pump turning on?
Everything turns on and stays on but no screen action on the 3 screens I have tried.
I can't say why the PC is not booting, i am only offering suggestions you can use to try and isolate the problem. As you suggested in your original post, Windows may be corrupted and reinstalling may solve the problem.
 
Jul 20, 2021
8
0
10
0
I can't say why the PC is not booting, i am only offering suggestions you can use to try and isolate the problem. As you suggested in your original post, Windows may be corrupted and reinstalling may solve the problem.
Yeah I realise and thank you I was just asking to see if you would know or not. I'm not sure how to reinstall windows when I can't even access anything 😩
 
Yeah I realise and thank you I was just asking to see if you would know or not. I'm not sure how to reinstall windows when I can't even access anything 😩
When you tried to boot a USB with Windows on it, was it plugged into the front of your case or into one of the USB ports on the back of the motherboard?
I would try booting the motherboard outside the case and if you still can't get into the BIOS, then contact ASRock about replacing the motherboard.
 
Reactions: T8imus
Jul 20, 2021
8
0
10
0
When you tried to boot a USB with Windows on it, was it plugged into the front of your case or into one of the USB ports on the back of the motherboard?
I would try booting the motherboard outside the case and if you still can't get into the BIOS, then contact ASRock about replacing the motherboard.
I tried both, the front and straight into the mb. OK I'll give it a go and go from there. Thanks for your time!
 

ASK THE COMMUNITY