• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Help: New Build - No Power [ASRock X570 / AMD Ryzen 5 3600x / Gigabyte GeForce RTX 2070]


Dec 5, 2013
Hi folks, I could use some help. All advice and assistance is greatly appreciated.

Problem: Finished my build. Hit the button - no power.

I've given as much detail as possible in this to give you the full picture of the build.

Here's my parts list:

Case - Antec NX600 Mid Tower 1 x USB 3.0 / 2 x USB 2.0 Tempered Glass Side & Front Window Panel Black Case with Addressable RGB LED Fans
PSU - Antec EarthWatts Gold Pro 650W 120mm Silent Fan 80 PLUS Gold Semi Modular PSU
Motherboard - ASRock X570 Phantom Gaming 4S AMD Socket AM4 DDR4 ATX HDMI Dual M.2 USB 3.2 Motherboard
CPU - AMD Ryzen 5 3600x 3.8Ghz 6 Core AM4 Overclockable Processor with Wraith Stealth cooler
Memory - Patriot Viper 4 Series 16GB Black & Red Heatsink (2 x 8GB) DDR4 3200MHz DIMM System Memory
Graphics Card - Gigabyte GeForce RTX 2070 Super Gaming OC 8GB Triple Fan RGB Graphics Card
Primary Hard Drive - Samsung 860 EVO Series 1TB 2.5" SATA III SSD

Build went well, some cabling wasn't obvious but we figured out most of it. I have three concerns from this, listed at the end of this post.

Firstly my main problem - no power when I hit the power button. No fans, beeps, life whatsoever.

There is a red LED illuminated on the case (top left light in this image) when the power cable is plugged in & powered.

No lights show on the motherboard. (Side note: I know there are four lights that should illuminate to indicate a problem with the CPU/RAM/VGA/Boot. I have nothing illuminating. Should I see something to indicate that the mobo is receiving power at least?)

Here's what I've tested:
  • Check the cable is plugged in - check. (You never know!)
  • Check the PSU is switched on - check.
  • Test power is coming from cable with voltmeter - check.
  • Test PSU independently for power - check (24 pin, 8 pin and molex connectors plugged into PSU power checker. PSU spun up and worked fine. Case fans/LEDs were also plugged into a SATA on that line so that also spun up and worked.)
  • Checked all cables were correctly and fully inserted.
  • Tested RAM - Checked RAM was fully inserted. Removed secondary stick of RAM to test just one stick, switched primary stick to test. (BTW using slot 2 & 4). I do have other RAM to test but it's lowly office PC ram. Worth trying?
  • Test GPU - tried three other GPU's (ancient stuff but they work).
  • Tested a different SSD and HDD.
  • Tested a different data cable and molex cable instead of SATA for SSD.
  • Tested just one ATX 4 pin connector into the (4+4) 12v power supply on the motherboard and then both connectors (See first 'cabling concern' point below).
  • Rearranged orientation of LED and power switch header connectors. (Literally just rotated the header pin so the text all faced the same way. Clearly grasping at straws by this point)
  • Tried different position for reset switch (See last point below)
Still nothing. I fear the motherboard may be a dud, I just don't want to accepted that fact.

Any ideas?

Cabling Concerns
- Atx power supply 8 pin (4+4) 12v.
On this board there are 8 female pins and the connector from the PSU has a split male 4+4 connection.

The pins on the MOBO are:

The split PSU connectors are:
[Angle][Square] [Angle][Angle]
[Square][Angle] [Angle][Angle]

As you can see, the left connector fits correctly. The second one does not match, but the angled male connections do fit into the square females. I've seen on forums that this is ok, but I wanted a more definitive answer.

- VDG cable
As you can see in this image, I have two connections. I used the top one, as a couldn't find a home for the VDG cable. I assume this is ok?

- Case Header Pins
As you can see on this post (top of PG.2) I have the same setup. I've tried moving the reset switch onto both 3/4 and 4/5. I think 4/5 is the correct setup.

Pin #1 - 5 is on bottom row, left to right.
Pin #6 - 9 is top row, left to right. (No pin #10 on top row, right side)

Power led + is pin #6 painted red
power led - is pin #7 painted purple
power button + is pin #8 painted orange
power button - is pin #9 painted black
HD led + is pin #1 painted green
HD led - is pin #2 painted yellow

pin #3 painted blue is vacant

Reset + is pin #4 painted grey
Reset - is pin #5 painted brown

Again I appreciate any assistance on this problem.

I'll be playing Rome Total War on my overheating 2013 Y510P in the meantime.