HELP!!! Radeon hd 7950 problem with video card Driver

gstead

Honorable
Dec 18, 2012
10
0
10,510
When I download the driver from amd for my radeon hd 7950 it causes a bunch of spots to appear randomly on the screen, but when I uninstall it the spots disappear. Here are some pictures of the spots.

http://gyazo.com/413a6c6dea10a9a17b5b7a081105e9f9
http://gyazo.com/065583bb71e6b273ffa6a6fc6670ed9e
http://gyazo.com/f8eb1dc66e43f4ef9dca800931b2b2a9

I have no idea how to fix this, I figured I was driving the wrong driver which i put for

step 1: desktop graphics
step 2: Radeon HD series
step 3: Radeon HD 7xxx series Pcle
step 4: windows 7 64 bit

I dled Catalyst Software Suite with .NET 4 Support and Latest Beta Driver with .NET 4.0 Support, but same problem occurs. I don't know am I downloading the wrong thing or something? Can you guys please help me?






 

gstead

Honorable
Dec 18, 2012
10
0
10,510
I have also tried putting in my sapphire radeon hd 7950 again into the motherboard, but still same problem. It stops only when I uninstall the AMD driver.
 

gstead

Honorable
Dec 18, 2012
10
0
10,510
So i did a fresh re install of windows, dled the driver again and when i dled it the samw rhing happens. Im getting frustrated. Could it be the software, monitor? I have no idea honestly. Any help would be greatly appreciated
 

gstead

Honorable
Dec 18, 2012
10
0
10,510
So I called AMD and told them about my situation. They suggested that my graphic cards may be busted and get a replacement. I think it could be cause when I play CS GO there are sometimes when the dots disappear but usually they reappear. Ill keep you guys updated and see how it works out
 

gstead

Honorable
Dec 18, 2012
10
0
10,510
I got my video card put it in and installed the driver. I checked my dxdiag and it showed this
http://gyazo.com/01bcb01c614d14142657e87133347f9c
http://gyazo.com/35273f7a6cd987c0ee4c59f21e72ec33
when I run counter strike global offensive I check the fps rate and it is the same as my integrated graphics. I checked my video card on device manager and it says its running properly
http://gyazo.com/dda2a344e54298bc267614f81554e1c7
I try to play far cry 3 and its the same when i had my integrated graphics. Any help is appreciated