Question Help. Screen gose off and pc dont turn off even with power button

Ojimoji

Great
Aug 27, 2019
124
3
85
0
Hi . Today i just play a 8k media downloaded for YouTube in windows and play that and cpu 78 percent load at 70 temp and after watch 10 minute of that clip i quit the clip and still cpu temp is 70 also cpu fan is 2500 rpm in hwinfo app.
Also in aida64 my cpu fan speed is disappeared . After about 30 or 40 minute am looking at screen to see what happens , now screen turned off , also cpu fan are work all fan case are work , graphic card fan work ,
And i press the restart button , and it dosen't work
And i hold power botton and doesn't work , still pc is on and no screen .
Please help. I build this pc a few days ago .
 

Ojimoji

Great
Aug 27, 2019
124
3
85
0
Now i switch off the psu from back of case , and pc turns off .
Now what can i do?
Should i plugged out the pus Cable?
Should i turn on the pc?
 

ionutnedelcu

Prominent
Oct 5, 2018
34
3
535
0
Yes, turn it on.

If in doubt, turn it off and on again.

Generally, the fans will keep blowing after the load has ceased, as the temperature slowly comes down. It's not instant. Once you boot up, you can check event viewer for additional info on what happened.
 

Ojimoji

Great
Aug 27, 2019
124
3
85
0
Tnx. After i turn on pc , i installed amd latest chip driver. And update to latest bios for my board.

I want to know what happens to my cpu . My cpu was under 80 percent load with 70 temp at high perforemace ,
And after that i close any progeam . And still cpu temp was 70 and fan very loud spining .
I mean cpu temp locked at 70 temp in 30 minutes
And after 30-40 minute screen goes off and that story .

So what is it ? Is a bug?
I think i had no chance to gaming with this cpu.
I hope that bios update and chip driver fix my issue.

Please if someone had similar problem as me or know my answer , tell me

Pc spec ;
R5 2600x stock cooler
Rog B450 f gaming
Corsair 16 lp 3000mhz
600w gold psu
 

ionutnedelcu

Prominent
Oct 5, 2018
34
3
535
0
If your CPU is staying under 80% load constantly, you check what process is causing this. Check task manager to see if it's a software issue.

I would also make sure the cooler is properly seated and have a look at the voltages in BIOS.
 

ASK THE COMMUNITY

TRENDING THREADS