HELP!!! update ASUS GTX 770 v BIOS failed

Andychang

Honorable
Nov 6, 2013
19
0
10,520
1
ASUS GPU Tweaker remind me to update my video card BIOS, during the updating blue screen jumped out and interrupted vBIOS upgrading process...

Please help me how to save my card, I just bought it for one week....

Thank you very much in advanced!
 
If the asus program, did a backup of the old bios of the video card.

Simply choose the file and re flash.

It should work after you flash the old bios firmware back if it backed it up.
Most programs do for such an event.

Hope it works.
If not like I said RMA the card explaining, the cause of the card not functioning was due to the ASUS GPU Tweaker, crashing during the flash of the new bios firmware.
 

Andychang

Honorable
Nov 6, 2013
19
0
10,520
1

Thanks, I am thinking if I could repair by myself? I can run windows system with iGPU and can find my 770 GTX card in device manager in safe mode. Any tools could help me fix it?
Thanks

 
Yep it will be without doubt a dead card if the flash of a new bios firmware was not fully completed.

RMA The card and get a replacement.
Also make sure you tell them that Asus tweaker was the cause of it.
And requested you to do a bios update. And crashed.
 

Andychang

Honorable
Nov 6, 2013
19
0
10,520
1

I have the bios, but the ASUS GPU tweaked and vBois flash tool do not work in windows safe mode;(
 
If your running the display output from the IGPU.

And have the card in the Pci-slot can you boot into windows.
Have a check in device manager and see if the Nvidia card shows up or is listed as an adapter.

If it does you should be able to run the asus updater and flash the card.

Or is this not the case ?

If not it`s an RMA for it sorry to say.
 

Andychang

Honorable
Nov 6, 2013
19
0
10,520
1


I tried, ASUS GPU tweeker and vBIOS flashing tool do not recognize the card.

GPU-Z can read the card but the BIOS shows "unknown".

I cant repair by myself.

WARRING to everyone: “NEVER TRY TO UPGRADE VBIOS WITH ASUS GPU TWEAK WHEN YOU RUNNING SLI !!!”
 

redlion57

Honorable
Dec 15, 2013
1
0
10,510
0
hi, i had the same problem.

Flashing vbios threw ASUS GPU Tweaker and the process break during the installation.
After that i was unable to boot, ********* upgrade!

I solved my problem, i put two graphic cards my new GTX770 (without alim) and my old GTX 660 (with alim) in order to boot on windows.
Then i used this tool for reflash the vbios of the 770 link here.
Now all is fine and my card run well.

Hope it can help you or other users.
 

ASK THE COMMUNITY

TRENDING THREADS