Question HELP? Why is my FPS so low in games?

Nov 19, 2020
3
0
10
0
Hey,
So this is my build https://ca.pcpartpicker.com/list/kshhZf
I also added a 2tb HDD for extra storage
I've had my computer for a couple of months now, and everything was great. But recently I've been dropping frames in some games (apex, overwatch). I usually run these games on high settings and until now it's been causing issues :(.
I've reinstalled windows,
Updated my bios and all drivers,
Uninstalled my graphics drivers using DDU, I did it all correctly but it's still acting weird at times.
I've been monitoring my CPU and GPU temps, but they seem to be normal (usually under 60 c for CPU, 80c for GPU and 110C for the junction point on my GPU).
Im going to be honest, I'm pretty quick at learning but this was my first time building a computer, so any help would be useful.
Thank you so much in advance!
 
Last edited:

EridanusSV

Upstanding
Aug 16, 2020
343
42
220
4
I havent even used 1/4 of it.
i forgot to mention i also added a HDD so my ssd doesnt fill up quick.
Have you installed and updated the m.2 through WD's software?

Maybe it needs an update and there could also be neat features such as RAPID, Over Provisioning, and TRIM that could help. (All features that I listed are Samsung SSD/m.2 features. Maybe WD has an equivalent feature that could help)

Also, make sure that your motherboard chipset is installed.

+ Make sure Write Caching is turned on under the device's Properties>Policies tab
 
Nov 19, 2020
3
0
10
0
Have you installed and updated the m.2 through WD's software?

Maybe it needs an update and there could also be neat features such as RAPID, Over Provisioning, and TRIM that could help. (All features that I listed are Samsung SSD/m.2 features. Maybe WD has an equivalent feature that could help)

Also, make sure that your motherboard chipset is installed.

+ Make sure Write Caching is turned on under the device's Properties>Policies tab
Hey Dude!
thanks so much for even caring to respond. I have downloaded everything you said and checked the write caching was on but still same issue :(
I’m going to open up my bad boy and clean everything, make sure everything is plugged in right, all fans are working and add more fans to my case. I’m not sure why but I suspect I might need it be be cooler.
If there’s anything else you think might work please let me know.
 

ASK THE COMMUNITY

TRENDING THREADS