Question Help with new gaming headset, Headset works flawlessly, but no microphone

Mar 8, 2019
24
2
15
0
alright ill try to explain this the best I can

a little background, I had a friend over housesitting while I was on vacation, and I allowed his kid to play games on my PC while they were here to keep him occupied, when i came home, he ROYALLY messed with a boatload of sound settings, I have no idea why.. as everything was working flawlessly. Fast forward 2 months, and i just bought a new gaming headset. Everything works FLAWLESSLY, however this Steel Series (yes i know.. steel series but its actually a solid headset for 7.1 and atmos) doesn't plug into the 3.5mm jacks on the mobo I/O, it has a USB that goes to a mixer (for game chat and game sound mixing) which then is output through a micro-USB to the headset (im assuming to power the RGB nonsense) however, i have ZERO sound even though the microphone is detected. Same exact thing on ALL of my gaming headsets, my other ASTRO A10's I literally have to use a USB audio "DAC" (thats their words, not mine) device and split the 3.5mm headset cord into a Y cord for separate mic/sound to plug into the USB device, and then voila.. microphone and audio work great, but now that I don't have the option (i do actually but want to use the USB and "mix amp" like knob, and go that route, as i think the sound is extremely better, especially with the atmos or 7.1 surround enabled. but for the LIFE OF ME I cannot figure out how to get the mic to work or what that darn kid did, ive tried everything. UN-Install/Install drivers, different USB ports, Windows audio troubleshooter, playing with different settings, etc, etc.

This new headset even has a button to manually mute/unmute the mic on the headset itself, not just by the mix amp alone. and every time I manually mute it, you can see the microphone bar detect that I muted/unmuted in windows sound settings, but other than that, the bar doesn't move and doesn't pick up my voice, doesn't pick up my voice in the steel series APP either, but if I hook it up by the aux port on the headset-split it into 2 separate 3.5mm jacks-then plug into my USB Sound card thingy, the microphone works perfectly

any ideas on what to do? I've tried 5 different headsets and multiple forums for troubleshooting and cant find anything that works, at this point im even willing to PayPal for the correct method to fix this annoying issue haha that's how fed up I am with it!

just in case.

gigabyte aorus z390 Pro Wifi
9700k @5Ghz
EVGA 2080 XC Ultra
Corsair 32gb of 3Ghz Ram
Corsair 850Watt PSU
Corsair obsidian 750D airflow edition
Corsair h100i
 

Karadjgne

Titan
Herald
I've got the steel series arctis 7, wireless, and I love it.

Mine too has a splitter, it's the antenna for the wifi. But has a plug-in for the pc speakers. Turn the headset on, disables the speakers. And vice versa. Far superior setup to the old USB headset I had.

USB by nature will only hookup after a 'handshake', so any unplug kills it. You also have to go into sound settings, playback, and set the USB for default speaker or the handshake doesn't happen.

Also check the line-in settings, if the ports are disabled / turned to 0, you'll get no sound/mic
 
Mar 8, 2019
24
2
15
0
the sound is perfect, just no microphone. and its set to the arctis 5 for sound and microphone in sound settings, and i know its registered because when i hit the mute/unmute mic button on the headset, you see the bar that tests the microphone in the windows settings move just a hair, but when its unmuted and i talk, it registers nothing whatsoever. totally lost and dont know what to do, all of the sound settings are set up to the headset, the handshake happened. but something else is preventing the microphone from working, i use the arctis 5 on my other computers and it works perfectly, i use my webcam microphone on this computer and it works perfectly, but if i use the arctis 5 through the usb it wont work at all, only the sound. any ideas what could be preventing it? windows troubleshooting says no error found,

ive restarted the windows audio services in command prompt and restarted it
all sound settings say "sound is set to arctis 5 game sound"
all mic settings say "sound is set to arctis 5 game chat"

there HAS to be some setting that my friends child did thats causing the microphone to not work

ive even uninstalled and reinstalled drivers! nothing works
 
Mar 8, 2019
24
2
15
0
honestly at this point im about to completely reset my PC. but scared to do so as i have a boatload of data

if i go to settings>update and security>recovery>reset this PC.........will it delete whatever settings my friends kid messed up and do a fresh install of windows and be back to how windows 10 comes by default? then i can add my software and apps back afterwards? and does it erase hard drives? i have an entire plex server with about 3,000+ movies on here and dont want to loose them but ill back up if necessary. does this sound like an option?

cause im TOTALLY fed up 110% at this point with the sound and crap, not to mention whatever he did with the bluetooth settings causes me to not have bluetooth anymore (which is the reason for the wired headset, and i even tried a bluetooth dongle to save time and that doesnt even work right, but this is besides the point)

any thoughts? or will the reset pc option happen like im assuming/hoping it will??

thanks in advance for the help!
 

ASK THE COMMUNITY

TRENDING THREADS