Question Help with new pc

May 25, 2019
4
0
10
0
This is my first pc build and I'm having some issues I did everything correctly to my knowledge but my graphics card isn't starting up and I'm getting no signal aswell as my keyboard and mouse aren't lighting up
My specs are:
Power cooler rx570
Amd ryzen 5 1600
G skill tridentz rgb 16gb ram
Wd blue 2tb harddrive
Thermal take 850w rgb powersupply
Rog strix b450-f gaming

Everything is brand new not second hand and it won't start despite all the lights turning on except the graphics cards fans so please help
 
May 25, 2019
4
0
10
0
Welcome to the forums!

Follow this guide thoroughly first: https://forums.tomshardware.com/threads/perform-these-steps-before-posting-about-post-boot-no-video-problems.1285536/
Go through every step thoroughly ( even if you have already done them ) - I understand it may be tedious, but it really does fix most boot problems.
Did everything listed discovered the system buzzer plugged it in and it's doing one beep and isn't stopping graphics card still isn't working
 
One beep bascially means it's booting normally. Does it just beep once or is it a repeated one beep?
Is it simply a black screen on the monitor or no signal at all?
Do the GPU fans start normally?
Are there any debug LEDs lit up on your MB?

Have you tried a different display cable or a different monitor first?
 
May 25, 2019
4
0
10
0
One beep bascially means it's booting normally. Does it just beep once or is it a repeated one beep?
Is it simply a black screen on the monitor or no signal at all?
Do the GPU fans start normally?
Are there any debug LEDs lit up on your MB?

Have you tried a different display cable or a different monitor first?
Its one continuing beep the gpu fans aren't spinning but everything else is working and I still have no signal as well as my mouse and keyboard not lighting up
 
Does your beep fit any of the following:
  • One short beep - VGA detected, No keyboard detected
  • Two short beeps - When using Crashfree to recover BIOS, the new BIOS is successfully recognized.
  • One continuous beep followed by two short beeps then a pause (repeated) - No memory detected
  • One continuous beep followed by three short beeps - No VGA detected
  • One continuous beep followed by four short beeps - Failure of Hardware component
Try breadboarding the PC, remove everything and leave only the essentials; CPU and cooler in MB, 1 stick of RAM, and PSU. See what happens - I should suspect you get 3 beeps for VGA as I don't believe you have integrated graphics.

Then add the GPU - then you may want to potentially swap the 1 RAM module.

Could well be PSU also, but we'd need to eliminate each component individually. Assuming you've followed the guide posted earlier thoroughly and installed everything correctly according to your MB manual.
 
May 25, 2019
4
0
10
0
At
Does your beep fit any of the following:

Try breadboarding the PC, remove everything and leave only the essentials; CPU and cooler in MB, 1 stick of RAM, and PSU. See what happens - I should suspect you get 3 beeps for VGA as I don't believe you have integrated graphics.

Then add the GPU - then you may want to potentially swap the 1 RAM module.

Could well be PSU also, but we'd need to eliminate each component individually. Assuming you've followed the guide posted earlier thoroughly and installed everything correctly according to your MB manual.
Still doesn't work but the lights on my mb are going red and yellow
 

ASK THE COMMUNITY

TRENDING THREADS