Question Help with USB Blue Yeti microphone?

ybteek

Honorable
Dec 13, 2014
19
0
10,510
0
Hello. I'll give you guys a basic run down on what happened and hopefully you can help me.

A few days ago, my blue yeti microphone wire became lose and instead of unplugging it, I pushed it back in, after the 3rd attempt it stopped working and then my harddrive connected on the same USB Hub as the microphone stopped working. I assume a power surge happened. I ordered a new wire/SSD. (the old wire does NOT light up my microphone)

When I plug the new wire into my microphone it lights up fine however, I am prompted with this message:


I've tried 2 different wires and they don't work. However before the main wire stopped working I switched it back into the microphone and it seemed to work fine but It died.

Followed steps:
I've tried most fixes on the internet such as
- Uninstalling the driver but it prompts this message

I do NOT have the "configure hardware" option in my control panel.
When I try to troubleshoot nothing comes up for hardware
I have tried changing power options

Does anyone have any suggestions on how I can fix my microphone? is it possibly broken? (I do NOT have another computer to test it on)

- Kind regards
T
 

ybteek

Honorable
Dec 13, 2014
19
0
10,510
0
So after ordering another wire, it does the same thing as the previous wire. It just lights up the microphone says this device has malfunctioned and doesn't even come up in my microphone options, any advice?
 

ASK THE COMMUNITY