Hey guys, i got a geforce 660 that i accidentely spilled a litle watee on while it was running, the computer is running but no

Nevry

Reputable
Apr 5, 2015
3
0
4,510
0
Hey guys, i got a geforce 660 that i accidentely spilled a litle water on while it was running, the computer is running but no display are shown on the monitor but the monitor detects the computer but yeah no display are shown. Im just wondering if the graphic card is broken or if you still can fix it. Sorry for my bad english.
 

SubZeroFlsh

Honorable
Aug 6, 2014
809
0
11,160
68


If there isn't a way of getting a replacement, that is the end of the road for your card. But try all you can.

If you connect your monitor to your motherboard and use integrated graphics, you can still use your PC until you get a replacement.
 

SubZeroFlsh

Honorable
Aug 6, 2014
809
0
11,160
68
Because it was running you have damaged it and mabye killed it. However try and clean as much water off the card as you can, but sadly because it was running while you spilted the water on it, it has done some fatal damage.

I reccomend contacting customer support, to see if you can get a replacement.


Hope this helps!
 

Nevry

Reputable
Apr 5, 2015
3
0
4,510
0


Thanks, i called them and they said that it was nothing that i could do.

 

SubZeroFlsh

Honorable
Aug 6, 2014
809
0
11,160
68


If there isn't a way of getting a replacement, that is the end of the road for your card. But try all you can.

If you connect your monitor to your motherboard and use integrated graphics, you can still use your PC until you get a replacement.
 

Nevry

Reputable
Apr 5, 2015
3
0
4,510
0
They said that it was nothing i could do so i took the graphics card and brushed it with a toothbrush and dryed it and guess what, it worked ! but the only problem now is that the fan is very loud. Any info or tips?
 

SubZeroFlsh

Honorable
Aug 6, 2014
809
0
11,160
68
Wow, consider your self luckey :D

Check the temps first, then remove the cooler and clean around the fan routor and blades, it may just be some dust or something that is causing this noise. But if it isn't too loud best to leave it.

Considering it was running, you are very, very lucky you still have working card. :D

Hope this helps!
 

ASK THE COMMUNITY

TRENDING THREADS