Discussion Hey guys I need some assistance with my pre boot pc

May 13, 2019
5
0
10
Ok so here are the specs.
PC CASE: Corsair spec-04
MB: gigabyte x470
CPU: AMD 5 2600
Cooler: Stock wraith cooler
storage: western digital 500 gigs ssd
PSU: EVGA G3 650w
GPU: ZOTAC 1050ti
Memory: 16 gigs of ddr4 (2x8) Corsair Vengeance
So I've been checking these forums a lot in the past week or so looking for answers but I just can't find one. This problem is very specific apparently. So this is all pre-boot. Whenever I turn on my PSU the fan doesn't spin if it's hooked up to the MB. I already did the paperclip test and my PSU is fine. Now however, I don't get my fans to spin up but the eagle led flashes white for half a second. I don't have speakers so I can't tell if it's trying to boot. I have reset CMOS twice. Just no fan action from anything. Any help is appreciated greatly. P.S this is my first build(I'm 14)
 
Some items to check.
  • Verify power is plugged into the 24-Pin ATX connector and 4/8pin CPU connector along with any the GPU has.
  • Strip it down to just you PSU, MB, RAM, CPU (heatsink and HS fan of course) and GPU. See if it will turn on.
  • Reseat the RAM and GPU. You'll usually feel a click and perhaps hear it as they pop into place. RAM often needs a firm push. Just not too hard.
  • Try with just one RAM module. Then try just the other module in another slot. To rule out a bad RAM module.
  • If it turns on. Plug in the monitor, keyboard and mouse. To see if it POSTs. If it does, keep adding components to the motherboard. Turning off before connecting each internal component.
 
May 13, 2019
5
0
10
Ok so here are the specs of my pc
MB x470 aorus
CPU amd 5 2600
GPU zotac gtx 1050ti
ram vengeance 16 gigs
ssd western digital
psu EVGA g3
cooler stock wraith
Ok so I have already posted and tried the one ram stick the reset of the cpu I've tried everything. I've done the paperclip test and my PSU is fine. for whatever reason the fan on my PSU doesn't spin when its plugged into my motherboard. The eagle on my x470 just flashes white for half a second or red and occasionally yellow. This is all pre boot I can't get my PC to post or boot. I'm stuck and I really need help.
 

ASK THE COMMUNITY

TRENDING THREADS