Hey guys, need some advice with my new processor.

Feb 7, 2019
1
0
10
0
Hey guys, so I recently was gifted an amd fx 8350 processor and just now got around to putting it in. So I followed instructions to the best of my abilities and took alot of precautions to now fry the processor, after getting it put in I tried to start my computer but all that happens is my keyboard and mouse briefly light up and then shut off. Nothing inside the computer turns on, none of the fans or anything. Just the keyboard and mouse. My motherboard is compatible with the new processor as well, it has the am3+ requirement. Anyone have any ideas?
 
Feb 5, 2019
2
0
10
0
Have you put all of the other necessities in your computer ex. ram and you cpu cooler. Also there is a plug near your cpu that is labeled cpu make sure you plug that in. If it is not a hardware problem you are having the problem that I had so what i had to do was i put in my bios on the disc (came with my motherboard) in the optical drive and then turned on my pc. It will boot to the bios there in the boot priority move all of your usbs to the front of the list so they boot first. Then put your windows 10 in, if a usb just plug it in, if on a disc then remove the bios disc and put in the windows 10. Then try to close out of bios and it will say it needs to restart. If none of this works try calling windows, they are very helpful and usually help with all windows problems just make it sound like you have a windows problem so say that you cant get your windows to boot up on your computer.
Hope I Helped
 

Similar threads


ASK THE COMMUNITY