Question Hi, I'd like some help about not being able to change resolutions in games

Jan 2, 2021
This only started recently, maybe a few driver upgrades ago. Games that used to have multiple resolution options now only shows 1920x1080, which is my monitor's native res. This is only in fullscreen mode, and switching to windowed made the multiple options available again. However, this made the games borderline unplayble due to horrible performance in windowed mode. I took 2 screenshots of a game affected by this.

Dark Souls 3:


I've tried a couple of fixes, but none of them have worked out:
  1. Tried setting the game's resolution in Geforce Experience
  2. Rolled back NVIDIA drivers to an older version
  3. Verified game integrity in Steam
If anybody can help me figure out a way to fix this I'd be immensely grateful. My PC specs are:
Dell Inspiron 7556
Intel i5-6300HQ
Geforce GTX 960M 4GB

EDIT: I found out the reason for my problem. Turns out I had the "Override Application Scaling" option enabled in my Intel graphics settings. I just had to disable that and everything was back to normal. Since I don't know how to delete or lock posts I'll keep this post here for anybody with similar issues.
Last edited:
"Intel" graphics settings? Why would that even apply if you're running a dedicated Nvidia GPU? It may be a laptop version of a 960, but it's still far better than a CPU's onboard graphics. You should have instead seen such an option in the Nvidia Control Panel ("Adjust screen size and position" tab).

So at this point I have to wonder if your system is incorrectly set to run on the CPU's onboard graphics.
Last edited:



Latest posts