Question High CPU temp with new custom loop

Jan 26, 2020
3
0
10
0
I used to have h115i platinum with 2 cases fans in front then 2 noctua fans then h115i rad then 2 ml fans and my 9900ks 5.1ghz 1.325v never hit 80C during realbench. They stay around 55c-65c with some random spike hit to low 70c only. Now with my new loop, it hit 80c within a few minutes then back down to 60c-70c. I though I could have better temp with my custom loop or at least similar but now I got worse. My loop is ek quantum kinetic 300 then 280mm 45mm thick rad in front, then to ek velocity block, then to 360mm 45mm thick on top, then to 140mm 45mm thich rear, then to gpu block, finally back to the pump. Pump and fan speed set to max doesn't change. The only good thing I have with this loop is my 2080ti now never excess 55c during stress test and 45c-50c during gaming.I don't know what is going on guys.
 

rubix_1011

Contributing Writer
Moderator
Radiators are relatively lower pressure drop/restriction than other components.

On the CPU block, did you setup the jet plate or just use it as it came from the box? Some of those had interchangeable jet plates and inserts and if you don't get them aligned correctly, it cuts off flow in the loop.

I only know this because it happened to me. I wasn't paying close enough attention on the re-assemble and noticed my CPU temps slowly climbed up. GPU temps likely would as well, unless you are running parallel CPU+GPU.

If you know for certain that you have flow through the CPU block, then it's most likely an incorrect seating of the CPU block on the IHS. Dismount the CPU block, clean thermal paste, reapply thermal paste, re-mount the CPU block, going in diagonal tension pattern on the screws. (Corner 1, opposite corner, adjacent corner, opposite corner) 1,4,3,2 then 1,4,3,2 then 1,4,3,2 until fully seated and tight.

Also, is the pump set to 100% speed, or a much lower speed? Until you know you have everything working, start at 50% and work up to 100%. Once you have everything working correctly, you can make pump adjustments...but D5's are so quiet anyway, why not just let it run 100%?
 
Jan 26, 2020
3
0
10
0
I use the jet plate come with the ek velocity and corsair xc7. Velocity has 4c-5c lower than xc7, so I know something is wrong with the cpu block. Pump is at 100%. Fan 100% and nothing can lower the cpu temp.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS