[SOLVED] High cpu usage on windows explorer

Status
Not open for further replies.
Jan 19, 2019
1
2
10
1


I had the same problem - tried a lot of things but nothing worked. I found an old post from a Windows 7 forum that said this can be caused by a file or shortcut on the desktop that doesn't have an icon. I looked on my desktop, found a pdf file without an icon, moved it off of the desktop, and the problem went away. I hope this helps.
 
Reactions: GallahadS1r and WWe

Tumeden

Respectable
Oct 15, 2016
449
0
1,960
101
Try running a program like CCleaner (clear temp files, etc)
There's quite a few random things that can cause higher usages in processes

Windows defender is also another culprit.
 

kazastyle

Prominent
Jan 2, 2019
12
1
510
0


i've cleared everything with cc cleaner. Also now i've noticed that firefox also using to much cpu.
On task manager only windowsexplorer and firefox are on very high power usage as well
 
Jan 19, 2019
1
2
10
1


I had the same problem - tried a lot of things but nothing worked. I found an old post from a Windows 7 forum that said this can be caused by a file or shortcut on the desktop that doesn't have an icon. I looked on my desktop, found a pdf file without an icon, moved it off of the desktop, and the problem went away. I hope this helps.
 
Reactions: GallahadS1r and WWe
Feb 14, 2019
1
0
10
0
uninstall the intel optane driver if installed and not used.
Don't try to uninstall the Optane driver. Once it's installed it cannot be uninstalled. The best you can do is uninstall the UI for it or the RST but the driver is installed in your BIOS and you can't stop using it. I tried and I have spent hours wasting time with Intel support (they are not worth your time - they told me to uninstall which they later admitted is IMPOSSIBLE).

Regardless, your issue is a known problem that is fixed in later drivers by disabling the feature causing you the issue - Pinning applications to the accelerator. Go into the UI for Intel Optane Memory or the Intel RST and disable Pinning.

https://www.intel.com/content/www/us/en/support/articles/000030517/memory-and-storage.html
 
Mar 12, 2019
1
0
10
0


I had the same problem - tried a lot of things but nothing worked. I found an old post from a Windows 7 forum that said this can be caused by a file or shortcut on the desktop that doesn't have an icon. I looked on my desktop, found a pdf file without an icon, moved it off of the desktop, and the problem went away. I hope this helps.
Thanks a lot! That totally fixed the problem for me.
 
Apr 21, 2019
1
0
10
0
Don't try to uninstall the Optane driver. Once it's installed it cannot be uninstalled. The best you can do is uninstall the UI for it or the RST but the driver is installed in your BIOS and you can't stop using it. I tried and I have spent hours wasting time with Intel support (they are not worth your time - they told me to uninstall which they later admitted is IMPOSSIBLE).

Regardless, your issue is a known problem that is fixed in later drivers by disabling the feature causing you the issue - Pinning applications to the accelerator. Go into the UI for Intel Optane Memory or the Intel RST and disable Pinning.

https://www.intel.com/content/www/us/en/support/articles/000030517/memory-and-storage.html
Yea that helped thanks a lot. I just went to add or remove programs and i unistalled intel Pinning something.
 

WWe

May 3, 2019
1
0
10
0
I had the same problem on my Windows 10 Thinkpad since the last update. Moving the files off my desktop also solved that problem. THX
 
Dec 11, 2019
1
0
10
0
Yea that helped thanks a lot. I just went to add or remove programs and i unistalled intel Pinning something.
Don't try to uninstall the Optane driver. Once it's installed it cannot be uninstalled. The best you can do is uninstall the UI for it or the RST but the driver is installed in your BIOS and you can't stop using it. I tried and I have spent hours wasting time with Intel support (they are not worth your time - they told me to uninstall which they later admitted is IMPOSSIBLE).

Regardless, your issue is a known problem that is fixed in later drivers by disabling the feature causing you the issue - Pinning applications to the accelerator. Go into the UI for Intel Optane Memory or the Intel RST and disable Pinning.

https://www.intel.com/content/www/us/en/support/articles/000030517/memory-and-storage.html
I have been fighting this problem on and off for a long time. None of the fixes I found with Google helped. I should have known the pros at Tom's Hardware would be the ones to find the real problem. Upgrading to the newest Optane drivers seems to have finally(!) killed this bug.

Thanks!
 
Dec 15, 2019
1
0
10
0
I've been tracking a similar issue:
Recently I've had the issue where on occasion (maybe once an hour or so max) the CPU would spike to 100% usage, used processexplorer set to latency 9secs to see that it was indeed explorer.exe causes the CPU spike, the spike would last 1-2 seconds and would hit the CPU so hard that it would garble audio for those 1-2 seconds.

Upon reading this thread I have just now tried uninstalling Intel Optane Pinning Explorer Extensions which were installed 5 days ago during routine updates, this may track with around the same time I noticed the issue, so I'm hopeful this is the issue, and thanks for everyone's due diligence here.

(I'm absolutely correct in assuming this is a useless software for someone running 2TB NVMe SSD for boot/gaming and 2TB 7200rpm HDD for storage, yes? :))

Thanks for all your help, I'm confident this is going to fix my problem as well, time will tell.
 
Jun 30, 2020
2
1
15
0
windows explorer.exe causing high cpu usage. when i restart the proccess it's ok for a while but it's starting again. Also i've noticed that it's using full only one core (screenshot).
Can you help me please ?

https://prntscr.com/m25qxc
https://prntscr.com/m25qwa
https://prntscr.com/m2525i
My symptoms were identical. I'd restart the explorer process, CPU would go to normal, but then remain spiked once I open an explorer window again.

I observed that once I opened the file explorer, 'quick access' in the URL bar would display a progress bar, as if a search was running.

bobpettit from an earlier post mentioned his fix was deleting a corrupt PDF on his desktop, so I looked for any "defective" files that I might have had. What I hit upon was a MKV file I had in my downloads folder that once opened, appeared corrupted in my player (because it would play the audio but not the video).

'Quick access' will show recent items you've opened (if the feature is enabled). In my case, it was. One of the recent items was that MKV file.

I disabled the 'recent files' feature, restarted the windows explorer process, opened an explorer window back up, and the high CPU use stopped. To disable/enable that feature:
  • Open Settings.
  • Click on Personalization.
  • Click on Start.
  • Turn off the Show recently opened items in Jump Lists on Start or the taskbar and in File Explorer Quick Access toggle switch.
You can then turn the feature back on after you've restarted windows explorer, but either delete the culprit file or never open it again!
 
Last edited:
Reactions: steveti
Jul 4, 2020
2
0
10
0
Fascinating. My cpu for Explorer runs around 5% all the time

If I delete thumbs.db from the desktop, explorer goes to zero!

I removed everything from my desktop (cut/paste to a folder in c:\temp) and started adding things back in slowly. Only added in items that had an icon. But thumbs.db showed up anyway, and once it did, cpu went back to 5% and stayed there. Not sure how to prevent it from getting created (but see below). Only gets created when something new gets added to desktop. Note, to see thumbs.db, you need to show hidden files in explorer settings.

Found this very helpful page

For me, looking in explorer View options, I did not have "always show icons, never thumbnails" checked, and I kept it that way (contrary to what the Raymond.cc page said). But I did have "display file icon on thumbnails" checked. I unchecked that one, and did "apply" and "apply to folders". I then cut/pasted all my desktop items to a folder in c:\temp, and then cut/pasted them back. A thumbs.db file got created on my desktop, but my explorer.exe cpu stayed at zero.

I am in Windows 10, with Windows running in a VMware Fusion guest OS (so my desktop is a shared folder that lives on the Mac hdd. Probably not relevant, but adds to the complexity of troubleshooting).
 
Last edited:
Jul 4, 2020
2
0
10
0
update:
I saved a spreadsheet to my desktop and cpu went back to 5% for explorer.exe. I changed my explorer view settings to checked: always show icons, never thumbnails (as raymond.cc suggested) and kept "display file icon on thumbnails" unchecked and explorer.exe cpu went to zero.
 
Jul 16, 2020
1
1
10
0
! ! ! ! ! ! ! ! !
I found this from thread earlier worked immediately without trying anything else and it had been bothering me for 2 weeks or more losing the ability to browse every so often during the day.
! ! ! ! ! ! ! ! !

My symptoms were identical. I'd restart the explorer process, CPU would go to normal, but then remain spiked once I open an explorer window again.

I observed that once I opened the file explorer, 'quick access' in the URL bar would display a progress bar, as if a search was running.

bobpettit from an earlier post mentioned his fix was deleting a corrupt PDF on his desktop, so I looked for any "defective" files that I might have had. What I hit upon was a MKV file I had in my downloads folder that once opened, appeared corrupted in my player (because it would play the audio but not the video).

'Quick access' will show recent items you've opened (if the feature is enabled). In my case, it was. One of the recent items was that MKV file.

I disabled the 'recent files' feature, restarted the windows explorer process, opened an explorer window back up, and the high CPU use stopped. To disable/enable that feature:
  • Open Settings.
  • Click on Personalization.
  • Click on Start.
  • Turn off the Show recently opened items in Jump Lists on Start or the taskbar and in File Explorer Quick Access toggle switch.
You can then turn the feature back on after you've restarted windows explorer, but either delete the culprit file or never open it again!
 
Reactions: GallahadS1r
Jun 30, 2020
2
1
15
0
! ! ! ! ! ! ! ! !
I found this from thread earlier worked immediately without trying anything else and it had been bothering me for 2 weeks or more losing the ability to browse every so often during the day.
! ! ! ! ! ! ! ! !
Just curious: what was the file type of the file causing the problem?
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS